Make px4_fmu-v6c_rtps?

make list_config_targets | grep rtps

Any px4_fmu-v6x or px4_fmu-v6c support?

Well I took a look at the Makefile, and created boards/px4/fmu-v6c/rtps.px4board. It now builds px4_fmu-v6c_rtps.px4. Something to play with for now.

Hi @cfrank
I tried this too still it did not work. Which firmware are using ? I tried with 1.13.1 and 1.13.2

  1. I copied rtps.px4board from /px4/fmu-v5 and pasted at /px4/fmu-v6c.
  2. build the file
  3. uploaded using qgcs
  4. PX6c wont start( the FMU red led blinks very fast for a while the stops and again blinks. This continues)
    Any idea why this happens ?

if you want to use microRTPS, then deactivate microdds:
in rtps.px4board

Can you just use FastDDS? There’s been some significant refactoring around micrortps client. The name RTPS is making way for DDS. In my setup I noticed the name change to microdds_client. Mine is configured on TELEM3 as follows:
microdds_client start -t serial -d /dev/ttyS1 -b p:SER_TEL3_BAUD

Today the refactoring appears to be complete, So let me try from scratch:
$ git clone GitHub - PX4/PX4-Autopilot: PX4 Autopilot Software --recursive
$ cd PX4-Autopilot
$ git submodule update --init --recursive
$ make px4_fmu-v6c_default
$ ls build/px4_fmu-v6c_default/src/modules/microdds_client/. # See client already here
Flash firmware: build/px4_fmu-v6c_default/px4_fmu-v6c_default.px4
I can now see microdds_client running:
microdds_client start -t serial -d /dev/ttyS1 -b p:SER_TEL3_BAUD

Now for the agent:
Oops: src/modules/microdds_agent is no longer in the src tree! WTF?

Ok thanks, is there any limitation in the number of topics(bandwidth or any other technical issue) i can send through urtps bridge ?

In my test I subscribed to combined_sensor. I assume bandwidth depends on your link speed. The PX4 6C has no ethernet (UDP), but I was able to run my TELEM3 baud rate up to 2Mbps no MCU bog down. I suspect you could move a large fraction of the orb at that rate.

BTW, have you found any documentation for setting up a serial agent on the recent branch?
I see a lot of agent references but no microdds_agent, no MicroXRCEAgent:

  1. Run an agent in a certain port, for example, 2018: MicroXRCEAgent udp4 -p 2018.