M8N GPS module keeps on blinking red

Hi everyone,

Im using pixhawk 6c with M8N GPS, the problem happened when I enabled this parameter CBRK_IO_SAFETY. I start getting error tune and the UI LED is blinking red. The 6C I/O B/E light blinking amber Tried to reset all the parameters to default, and upgrade PX4 firmware again but nothing changed.

When I upgraded to Ardupilot firmware everything worked fine, the LED is green and 6C I/O B/E light went off.

Any advice please, I need to work with PX4

Update: I tried to downgrade PX4 firmware, the B/E light went off but the GPS module blinking blue now. QGC status shows GPS disabled. I changed COM_ARM_WO_GPS to require GPS lock to arm, the status shows GPS Error !!!

What GPS module do you use exactly? M8N is only the name of the Ublox chip model.

CBRK_IO_SAFETY is used to enable or disable the safety switch, on older GPS like Here2 GPS it was embedded with the sensor.

If you enable the safety switch functionality, GPS or other status LEDs will be flashing red until the switch is enabled (what I remember - it was some time since I used it).

I’m using this one

I’m trying to understand why with ardupilot its blinking green indoor, while with PX4 its red indoor also.

I disabled the safety switch and tried again but still blinking red with I/O B/E blinking amber