LPE related parameters are missing QGroundControl after update to PX4 1.5.1 firmware


we updated our Pixhawk 1.0 firmware to PX4 1.5.1 and now all parameters related to LPE are missing in QGroundControl. The release file said that EKF2 is the default state estimator now, but LPE can be used for indoor and R&D. How do we bring those parameters back? We can switch to LPE in System parameters, but we still don’t see LPE_ parameters.

One more question - is it possible to use PX4 1.5.1 with PX4FLOW? Will EKF2 work fine with PX4FLOW data?

Thank you

Try switching to LPE, rebooting the autopilot, and then refreshing the parameters after reconnecting. They haven’t disappeared, they’re just hiding to save time during the initial param sync.

We tried that, but it is still not visible. Also, new 1.5.1 firmware is not happy with the battery charge even though it is 100% charged. So Pixhawk does not initialize fully (reports critical battery). We use 3DR Pixhawk 1.0 with Iris+ and we tried it with QGroundControl 3.0.1 and 3.0.2 and the latest from the dev branch – same result.

Does 1.5.1 breaks backward compatibility with Pixhawk 1.0 somehow?


It definitely didn’t break Pixhawk 1 compatibility. One thing you could try is doing a fresh flash and then reselecting Iris under airframes and rebooting. This will reset all params to default + iris config. Make sure you backup any changed parameters you want to save.

what i can tell, when you come from an early version with LPE and just upgrade without resetting the params you get a strange behaviour with flips and crashes :frowning:

The default stable version of PX4 seems disable the LPE module. If you needed, you should compile the source code, please refer the reply https://github.com/PX4/Firmware/issues/6091.