Can not change to LPE using recent firmware


1- I am using Pixhawk 1 (px4fmu-v2)
2- I use QGC to upgrade to the recent version, 1.5.3
3- The default estimator is ekf2, but I choose LPE, as I need to fly indoors using mocap
4- I reboot, but I don’t find the LPE tab in QGC, only the EKF2 tab with its full parameters.

Also, in QGC, it shows me that the firmware version is 1.5.1dev, although I upgraded it to 1.5.3 using QGC.

Are there any parameters that need to be set in order to change to LPE?


LPE is not built by default for fmu-v2
Uncomment LPE, comment out EKF2, set the parameter to use LPE and then build and flash the code and it should work

How to set the parameter to use LPE before I build?

You can set it as normal in QGC but it shouldn’t matter, you can do it afterwords.

Now there is another problem!

After making the mentioned modifications, the Pixhawk does not connect to QGC (v3.0.2). It says: could not connect to vehicle.

If I revert the change, it connects normally!

What could be the reason?

Have you tried setting the parameter before flashing the firmware that has LPE included? PX4 isn’t particularly robust when it comes to trying to start apps/modules that don’t exsist, so that may be the cause after all.

How do you try to connect?

  • Works now
  • I enabled attitude_q estimator as well
  • reflashed
  • works!