Landing problem

#1

Hello!
I have experienced some problems when I want to set up the landing procedure.
I have a flying wing with PX4 software and Qgroundcontrol version 3.3.2, and I want to setup the Return To Home action.
When I put it in a Return Mode, everything is as should be, until the flare phase. When it comes to the flare phase, the aircraft never land, it pull the motor on, and flyes away.

I have set each parameter on which it depends. The flare altitude is 2m, the flare distance is 15m.
When it comes out of the loiter phase, the aircraft shut down the motor and make the land slope correctly. At about 2-3 meters, when the flare is suppose to begin, it start up the motor and fly away.

I don’t know what I do wrong.

Maybe you can help me to solve this issue.

Thank you very much.

#2

That sounds like the land abort is kicking in. The abort can be configured for several things. Upload a log as I’m sure that will show why.

Chris

#3

Thank you very much for your answer. I will make today another flight and I will upload the logs after that.

Thank you

#4

Hmmm… I don’t think there is auto abort in PX4 fixed wing, is there? I’m wondering if your landing and flare parameters aren’t set up the way you need them?

#5

I don’t know if it’s set correctly. I think it is, but maybe I am missing something and I don’t figure it out what.
I attached 2 photo with the settings of the parameters. Today I was at the field, but for some reason that I miss, it didn’t save the logs, so I don’t have what to show you.
Next days I will try again.

Thank you.

#6

I see you have FW_LND_USETER enabled. how are you estimating the terrain during landing? I’ve never used that parameter before so I don’t know how it works, but that is one obvious difference from how I do things.

#7

I tried with different setup. I tried with this parameter disable at the beginning, and after that I enable it, to see if it’s any difference. It isn’t.

#8

Your throttle limit altitude is too low. That is altitude at which the aircraft will cut the motor. Because your aircraft will never achieve 0.0 meters it will never kill the motor after flare causing the flyaway. I recommend setting your flare higher to like 3 meters, and your FW_LND_TLALT to 3 meters as well.

#9

Ok. I will try. I remember that was set at 5 meters at the beginning, but I will try again.

#10

Actually just make your flare altitude and FW_LND_TLALT the same. Doesn’t matter what altitude I’d say try it higher than 1 meter at least.

#11

Yo thanks to the comment and to man who post this thread, I learned a lot God Bless You All.