jMAVSim prints "Init Mavlink" repeatedly

#1

I am running jMAVSim on HITL mode with a Pixhawk 1 connected on a Windows system. However, everytime I run it, it prints “Init mavlink” in the cmd termnal and well as on the GUI.

It doesnt allow me to type in any commands from the cmd terminal. From QGC, I can send takeoff and land messages, but the messages only show up on the cmd terminal and the GUI but have no affect on the simulated drone or the other values. (I can tell the actual Pixhawk responds to the commands because changing the LED changes from armed to disarmed etc).

This is what the cmd terminal shows:

Init MAVLink
Init MAVLink
Init MAVLink
Init MAVLink
MSG: ARMED by arm/disarm component command
MSG: [logger] file: /fs/microsd/log/2019-01-08/04_15_1
MSG: Takeoff detected
Init MAVLink
Init MAVLink
Init MAVLink
Init MAVLink
Init MAVLink
Init MAVLink
Init MAVLink
MSG: Landing detected
Init MAVLink
Init MAVLink
Init MAVLink
Init MAVLink

How do I stop the init mavlink message from appearing? Do I need to do something to ensure mavlink is actually initialized?

#2

Thanks for the note. I’ve fixed this yesterday:


#3

Thank you! Is there a reason the simulated drone is not affected by any command sent from QGC? For example, it says takeoff detected but the drone never moves (similar for landing).

#4

Are you using px4_fmu-v2_default?

If yes it doesn’t compile pwm_out_sim and you need to enable it:


(same as this: https://github.com/PX4/Firmware/issues/10899)

Also, there is currently a bug that the default sensors are running in HITL mode:

#5

The issue was V2! jMAVSim responds how I would expect it to now, Thank you!

Regarding the default sensors running, I assume since https://github.com/PX4/Firmware/pull/11044 is merged that the problem should be fixed. What are the effects of the default sensors running? I don’t quite understand.

#6

The problem is that the HITL fake sensor publishes sensor data as well as the real sensors, so then the EKF receives both and doesn’t know which ones are right: Am I flying or sitting on the desk? :smile:

#7

I see! Could that be causing the No global position failsafe error?

#8

I see! Could that be causing the No global position failsafe error?

I’m not sure.