Issues in HILS simulation with PX4, QGCS/MP and FLIGHTGEAR

Hi,

I am trying to do hardware in loop simulation of Quadcopter or Plane aircraft using PX4 autopilot, Flightgear, QGCS/MP ground control station and RC.My problem definition is:

  1. Control the quad copter or plane using RC -> i should be able to see simulation in Flightgear. In this, RC is connected to PX4 autopilot which in turns communicate with QGCS / MissionPlanner which is connected to Flightgear where i want to see the simulation.

This is my understanding of the problem but if there is any better way to see the simulation of aircraft in Flightgear using PX4, please guide me.

  1. Second problem is: I need to stream the camera view of Filghtgear to another PC and do image processing of the scene and then through mavlink communication to PX4 autopilot, i want to see the simulation of my algorithm in Flightgear.

I have tried following things:

Connecting FlightGear 2016.4.4 via QGroundcontrol v3.1.2 (Followed the procedure given in http://ardupilot.org/dev/docs/flightgear-hardware-in-the-loop-simulation.html ): But facing following issue:
qgc>widget manu>HIL config

when i press start i am facing issue :

  1. Uploaded the PX4_quad_hil firmware and again did the same thing of connecting Flightgear to QGCS. Again same issue.

Got the firmware from: https://github.com/ArduPilot/binary/blob/master/History/Copter/stable/PX4-quad-hil/ArduCopter-v2.px4

In both cases, after specifying Flightgear fgfs.exe directory path i am getting issue :

  1. i have tried with mission planer v1.3.43 also but in simulation tab of mission planner it is not giving an option to connect with flightgear.(followed the procedure given in http://ardupilot.org/copter/docs/hil-quad.html )

Tried with old version of mission planer that is 1.2.55 i am getting this issue