Installed then

I installed It worked and I could launch jMAVSim and the px4 console. I then tried install, but I run into a catkin build error.


WARNING: Your workspace is not extending any other result
space, but it is set to use a linked devel space layout.
This requires the catkin CMake package in your source
space in order to be built.

[build] No packages were found in the source space ‘/home/kinghoof/catkin_ws/src’
[build] No packages to be built.
[build] Package table is up to date.
Warning: generated devel space setup files have been deleted.
Starting >>> catkin_tools_prebuild

Errors << catkin_tools_prebuild:cmake /home/kinghoof/catkin_ws/logs/catkin_tools_prebuild/build.cmake.007.log
CMake Error at /home/kinghoof/catkin_ws/build/catkin_tools_prebuild/CMakeLists.txt:12 (message):
The catkin CMake module was not found, but it is required to build a linked
workspace. To resolve this, please do one of the following, and try
building again.

  1. Source the file from an existing catkin workspace:
    source SETUP_FILE

  2. Extend another catkin workspace’s result (install or devel) space:
    catkin config --extend RESULT_SPACE

  3. Set catkin_DIR to the directory containing catkin-config.cmake:
    catkin config --cmake-args -Dcatkin_DIR=CATKIN_CMAKE_CONFIG_PATH

  4. Add the catkin source package to your workspace’s source space:
    cd SOURCE_SPACE && git clone GitHub - ros/catkin: A CMake-based build system that is used to build all packages in ROS.

cd /home/kinghoof/catkin_ws/build/catkin_tools_prebuild; catkin build --get-env catkin_tools_prebuild | catkin env -si /usr/bin/cmake /home/kinghoof/catkin_ws/build/catkin_tools_prebuild --no-warn-unused-cli -DCATKIN_DEVEL_PREFIX=/home/kinghoof/catkin_ws/devel/.private/catkin_tools_prebuild -DCMAKE_INSTALL_PREFIX=/home/kinghoof/catkin_ws/install; cd -

Failed << catkin_tools_prebuild:cmake [ Exited with code 1 ]
Failed <<< catkin_tools_prebuild [ 0.0 seconds ]
[build] Summary: 0 of 1 packages succeeded.
[build] Ignored: None.
[build] Warnings: None.
[build] Abandoned: None.
[build] Failed: 1 packages failed.
[build] Runtime: 0.1 seconds total.
ROS catkin_ws setup.bash already in .bashrc
./ line 73: /home/kinghoof/catkin_ws/devel/setup.bash: No such file or directory
Downloading dependent script ‘’
–2018-06-01 08:07:24--
Resolving (…
Connecting to (||:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 1018 [text/plain]
Saving to: ‘STDOUT’

  •               100%[===================>]    1018  --.-KB/s    in 0s      

2018-06-01 08:07:25 (30.2 MB/s) - written to stdout [1018/1018]

bash: line 26: hash: geographiclib-get-geoids: not found
bash: line 30: hash: geographiclib-datasets-download: not found
OS not supported! Check GeographicLib page for supported OS and lib versions.