How to Setup PX4 on Snapdragon Flight Controller

I want to set up PX4 on Snapdragon Flight Controller. However, when I checked the user guide from website “”, all steps seem to work with Pixhawk controller but not Snapdragon Flight Controller. I wonder if I can follow exact the same steps to set up PX4 on Snapdragon.

Most of the user documentation for setup and flying are 1:1 correct. However, you need to refer to for flashing the software first.

Hi Lorenz Meier,

Thank you for your reply.
I just checked the website “” and want to confirm again that to flash software, I need to follow steps 1.2.2 and 1.3. Am I right?

Yes, this is correct.

Hi everyone,

I have followed the procedures 1.3 in website “"
However, when I type command “make eagle_default”, I got the error message " No rule to make target /home/jimson/Qualcomm/Hexagon_SDK/2.0/lib/common/rpcmem/UbuntuARM_Debug/rpcmem.a', needed bysrc/firmware/posix/mainapp”.
Does anyone have the same issue?


Yes this seems to be similar:!topic/px4users/6-J3GPnZLmg
But I cannot test it myself, since I don’t have the same setup.

Also check out this issue

Thanks for all the help.
I successfully built the code and ran the command “./mainapp mainapp.config”. After running the command, I got “PX4 Ready to Fly” and

/media/intrinsyc/BigDrive/Project/APQ8074Flight/LNX.LER.1.0-68037/APQ8074Flight/oe-core/build/tmp-eglibc/work/cortexa8hf-vfp-neon-linux-gnueabi/adsprpc/1.0-r0/adsprpc-1.0/src/fastrpc_apps_user.c:136:failed to create tls key/media/intrinsyc/BigDrive/Project/APQ8074Flight/LNX.LER.1.0-68037/APQ8074Flight/oe-core/build/tmp-eglibc/work/cortexa8hf-vfp-neon-linux-gnueabi/adsprpc/1.0-r0/adsprpc-1.0/src/listener_android.c:112:listener using ion heap: -1
Segmentation fault

In addition, when I open QGC, it doesn’t automatically detect the Snapdragon Flight controller board so I can’t follow “”. Does anyone know how to let QGC detect Snapdragon Flight?

It would be nice if there was an easier way to load the firmware as this is very intense. I spoke with intrinsyc a week ago and they informed me they were changing the terms of the firmware distribution so we didnt have to build it on every board. Has that taken effect yet and is there an easier way to get this board running…

I am hoping some can assist me here, I have downloaded all of the qualcomm files from intrinsyc support page and am going through the process of the px4 dev page to get this board running. I have got to the point of downloading Hexagon 7.2.10 Linux toolchain and the Hexagon 2.0 SDK. The issue I am having is that Hexagon 7.2.10 Linux toolchain does not exist for the SDK as far as I can tell and the SDK add on is required. What commands should I be using to finish this step?

Can you describe which exact files that are mentioned in the dev guide are missing?

@LorenzMeier I cannot find the entire hexagon 7.2.1 tool chain file and do not know what to do.

Please follow all the steps here:

You need to file the request with Qualcomm to obtain the toolchain.

Thank you. I will do that, the documentation was not entirely clear on that part.

I’ve updated the documentation to highlight this more clearly.

Thank you. I have another issue when I try to flash the firmware and reboot the bard to the bootloader. What happens is I run the fastboot devices command and it says “fastboot devices no permissions fastboot”

Any ideas here? I have tried everything I can think of to get the fastboot to detect the FC with no luck.