How do I install an older version onto board?

I would like to install 1.5.5 onto a Pixhawk 1. I tried downloading the source zip and then using “make px4fmu-v2_default” to install. No dice, it says I must use Github to download this repository. What am I missing?

That’s because of the git submodules that include things like NuttX, Mavlink, etc.

Did you see the under the release?

I tried all of the file formats, 2 zips and the tar.gz. I got the tar.gz to work randomly a while ago, but not since. I ended up following the standard build instructions, but before I ran ‘make px4fmu-v2_default’ I ran ‘git checkout 00334ad’. It worked out perfectly.


Can you please explain how to solve the issue ?

  • Go to
  • Click the green"Clone or download" on the top right hand side
  • Click “Download ZIP” and save to your folder
  • Unzip the file.
  • In QGC, choose “Custom” and point to the folder you save the ZIP and choose the version you want installed.

Good luck.

i understand that this is for using a .px4 file. But i am trying to build the .px4 with few modifications according to my appication.

Did you solve your problem? Actually, I have the same problem. I downloaded and modified 1.5.5 firmware. And then I tried to build it but it did work because I did not download from repository… How did you solve the problem?

@DoHyeung_Kim @JonReacher @sivateja619 I had same issue because I needed v1.8.2 instead of the current 1.9.2 release. So here’s what I did:

  • I cloned the branch using the tag v1.8.2 from my command line using:
    git clone --branch v1.8.2
    git checkout tags/v1.8.2

  • Then I went ahead to build in the normal way.

The needed submodules and all were fetched and updated during the build process. Hope that helps someone.