High Vibration

It’s a 770cm quadrotor with 17inch propellers, T motor MN4014 KV400, T motor air 40a esc. The vibration level is kind of high. I tried the damping system or damping foam but they make the vibration worse. I think that because the Pixhawk 6c has an internal damping system. I tried to tune the filter. Here are the logs:


The 6C does not have that. The 6X does.

Holybro 6c doc says they have it.

I’m having a similar issue with a modified Typhoon H480 with a PixHawk 6C. It has dual SpeedyBee 60a 4-in-1 ESC’s. It runs smooth under Vehicle Setup when testing the actuators but, vibrates under radio control. So, I’d very very interested in a fix as well.

Discovered my issue. Just not sure how to fix it. The motors powered by the ESC are not balanced, as far as output. Manually adjusting the parameters for yaw rc control settles out the vibrations, but… I don’t know if that is the correct solution.

My yaw RC input looks fine. If the motor didn’t have vibration in the setup, it should be good. You can test the vibration with your phone and speed up the motor.

I corrected my issue. One I shielded the GPS cable and corrected the yaw orientation for one of my magnetometers. Not sure how that happened.

Do you have a link for this claim?

What is the yaw parameter field for rc that you adjusted . Thank you

Here is the Holybro documentation for Pixhawks 6c.

Oh whoops, I was wrong. I just opened up my 6C and there is indeed some foam between the sensor board and the main board. I don’t know the performance in terms of vibration isolation but there is certainly some of that.