Help with pixhawk 2.1 and peripherals

I’m not sure where to start, but I’ll try to be clear. I am building a wing (Drak by Ritewing) that will be capable of long range flights but I plan to use it for mapping. I will be using the Crossfire diversity system from TBS for rc control and TBS 2.4vtx for video. I originally planned to us a Vector flight controller until I was told that the Pixhawk 2.1 was the controller for the job. I am thinking of getting 2 Here GNSS for GPS and a LIDAR-Lite 3 Laser Rangefinder also. I do have a pitot installed on the wing for air speed but I’m thinking I’ll need to get one that goes with the pixhawk (help here, will the eagletree one work with pixhawk). I am also using an Eagletree antenna tracker for the video (I’m not sure if this matters or not but I just want to be sure everything is mentioned).

What I need help with is guidance/ direction on if and how to make all these things work together. Also, am I missing anything? I will be wanting the Pixhawk to trigger a camera also, I have not settled on one yet, but am leaning towards the Canon - PowerShot G7 X Mark II.

I am completely new to Pixhawk and I am no computer programmer. I really want to learn this and if there would be someone who could help me out a bit I would be extremely greatful!!


…I am also reading the power brick is only 30A. I am assuming that it is not going to work with the 85A setup I have. Are there other options?

The eagle tree airspeed sensor works, but I’d also consider these newer options.

You’ll need something to actually trigger the camera. I’d start by looking here.

General documentation for getting started.

Thanks for the info! Airspeed sensor ordered.

Is anyone having an issue with the SDP3x Airspeed Sensor not detected by Pixhawk? I have it plugged into the I2c port on a Pixhawk 2.1 Cube using the PX4 1.8.0 firmware. I’m trying to get the Generic Delta VTOL airframe profile working. It seems not to detect anything plugged into the I2c port. Thing is, this sensor worked on previous firmware builds. I ran a test and loaded on Ardupilot and the sensor shows up so it’s a firmware problem. Can’t progress with out it. Anyone else having this problem? Any solutions???

I recommend you file a new issue on this.

Good luck.

Hi Rollys,
will do, thanks!