HELP! Crazy oscillation of drone in position mode

#1

Hi all,

I went to test my drone with pixhawk 4 in position mode and it acted strangely. It works perfectly fine in manual mode but when i switch to position mode, the drone starts twitching in all directions and eventually spins out of control. If anybody knows how to fix this please help!! Thank You!

Here’s my setup:

Frame: Storm Anti-gravity 640mm

Motor: T-motor 380KV

ESC: Hobbywing 40A

FCU: Pixhawk 4 + GPS

Telemetry: RFD 868x

Battery: 6s 4000mah

TX/RX : Futaba T14SG

Flight review from PX4 io:

I started off with manual and then switched to position (green portion). You can see that the thrust goes up and down which was what i observed during flight where the drone went up and down. I did not touch my transmitter controls at all.


#2

Hi @Joshua
Can you share the link to the log?
It’s likely in-air landing detected and you need to make sure you have the hover throttle configured correctly.

#3

Hi @bkueng here’s the link:
https://review.px4.io/plot_app?log=f755553c-daf1-4b32-a716-d51f817594f5

thanks!!

#4

@bkueng could it also be the gains under parameters or the airframe type?

#5

It’s indeed in-air land detected. Make sure to configure MPC_THR_HOVER, looks like it’s around 25%. But first I’d make sure to balance the vehicle a bit better, it looks imbalanced.
If you still have problems then, increase MPC_Z_VEL_I to about 0.08.
The tuning gains look ok, you might be able to improve that a bit, but you can do that afterwards.

#6

@bkueng Hmm… my parameter settings for MPC_THR_HOVER is set to 50% . I tried reducing MC_PITCH_P and MC_ROLL_P to 5.5 and it worked. Just that the drone only waits for the drifting then corrects back to its position. Is that normal ?

#7

Can you elaborate? Generally reducing tuning gains (too low) will give you a more sluggish behavior.

#8

ok so after i arm and took off in manual mode, I hovered about 3 metres from the ground. I then switched to position mode to test it out. The wind was coming in strong from northeast direction (with ref to drone). The wind pushed the drone off its position by roughly 60cm towards southwest direction and then it corrects itself vigorously. How do I make the drone less sluggish and respond immediately instead of having to my off its locked position and then responding? Thanks!! @bkueng

#9

You need to tune the vehicle, starting with the Rate Controller, up to the Velocity and Position Controller: https://docs.px4.io/en/config_mc/pid_tuning_guide_multicopter.html

#10

@bkueng so basically trial and error until I get the perfect rates?

#11

If you want to call it that way, but it’s a systematic approach. And it takes some practise.

#12

@bkueng Thanks very much for your help!! I’ll go play with it