Compass Configuration Question

#1

I am using an mRobotics Pixracer with Arduplane 3.8.2. I’d like to use only a single external compass on a flying wing. Can someone tell me exactly what the setup in Mission Planner should be?

In the Mission Planner GUI I have:

Enable Compasses = checked
Primary Compass = 2
In the Compass #2 box I have both “Use This Compass” and “Externally Mounted” checked, and no rotation.

Below is are excerpts of the compass section from the parameters file. I appears that both compass #1 and #2 may be active. Am I reading this correctly? If so, how can I turn off the internal compass(es)?

COMPASS_EXTERN2,1
COMPASS_EXTERN3,0
COMPASS_EXTERNAL,0
.
COMPASS_OFS_X,-82.35384
COMPASS_OFS_Y,57.9438
COMPASS_OFS_Z,-56.48816
COMPASS_OFS2_X,-172.7349
COMPASS_OFS2_Y,-342.9156
COMPASS_OFS2_Z,-194.0893
COMPASS_OFS3_X,0
COMPASS_OFS3_Y,0
COMPASS_OFS3_Z,0
.
COMPASS_ORIENT,0
COMPASS_ORIENT2,0
COMPASS_ORIENT3,0
.
COMPASS_PRIMARY,1
COMPASS_TYPEMASK,4096
.
COMPASS_USE,0
COMPASS_USE2,1
COMPASS_USE3,0

While this setup achieves an accurate heading, I get ERROR COMPASS VARIANCE alarms whenever I turn the plane. I think tow or more compasses have conflicts.

How do I disable the internal compasses on the Pixracer?

Thanks,

Paul

#2

Tried this setup and it also does not work right. I get ERROR COMPASS VARIANCE when I turn the plane and the heading is off by something between 90 and 180 degrees.

I’m using an mRobotics micro GPS:

https://store.mrobotics.io/product-p/mro-ugps-samm8q-01.htm

On the GPS/compass unit I have the little white arrow mark above the connector facing forward.

Arduplane 3.8.2, Mission Planner 1.3.50.

Thanks,

Paul

#3

Perhaps try discuss.ardupilot.org

#4

Thank auturgy, I’ve already entered a similar post there as well. I thought this forum may be more specific to the Pix products and would get traffic by folks more experienced with the Pixracer.

Paul

#5

@flyingw, hi Paul, there is a lot of confusion at the beginning, what’s the right forum to choose. I also have a Pixracer and using sometimes ardupilot and sometimes PX4. So you have to switch from one forum to the other. These forums are related on the firmware you use. And then the Ground Station. QGC is more oriented PX4 firmware, but can manage both firmwares, and Mission Planner is dedicated only to Ardupilot (Arducopter, Arduplane,…) firmware. It could be interesting having a basic topic on each forum explaining this…

#6

Found the problem - the GPS/compass unit I was using was not being detected by the Pixracer.

Thanks all,

Paul

#7

So - Paul can you tell me how you fixed it?

#8

Dear Community

No matter what I do I get compasses inconsistent. I would like to ask you the orientation of external compass ( HMC5883L) . My opinion just Rotation_180 ( Because compass is upside down).

Schematics Here