Gazebo cannot open some worlds with PX4

Hello all

I’m having trouble while using gazebo with px4 (without ROS). When I run the command

    make px4_sitl gazebo

It works normally: gazebo opens and px4 runs.

However, if I want to open another world on gazebo with

make px4_sitl gazebo_iris__warehouse

It stucks at this point and gazebo does not open as well as px4

If I try to open the world manually just with gazebo like this, gazebo is not opening again

The thing is, some simple worlds works without problem like,
But more complex ones does not work. I dont think the reason is my system. I don’t know gazebo or px4 causes the problem but default gazebo worlds I tried has worked so far. My best guess is this is some kind of plugin problem. I appreciate any help you can provide.

OS: Ubuntu 20.04 LTS
Gazebo version: Gazebo 11

Have you tried looking at the verbose output? e.g.

VERBOSE_SIM=1 make px4_sitl gazebo_iris__warehouse

Hello again, quick update

As can be seen above, in the file, the accessories part models does not exist in the corresponding model folder. When I deleted this part, gazebo worked seamlessly.

I could not find the files in the PX4-Autopilot repository as well.

Is there anyone who knows the reason why these files does not exist in the model folder while the script tries to call it?

@ytaskiran It is not supposed to be there, and it will be automatically pulled from the gazebo model database. That is why I asked you to look at the debug outputs of gazebo by adding VERBOSE_SIM=1

1 Like