Flashing Pixhawk 4 FMU-v5 Bootloader..?

Some months ago, I bought a Holybro Pixhawk 4 directly from Holybro…at the time, QGC, according to Github, had 844 Issues… my other option was to use Mission Planner & Ardupilot/Arducopter… Not knowing a thing about M/P I read the docs and watched some videos on Youtube. Painless360 stated that Pixhawk 4 would run on M/P… using Ardupilot/Arducopter (Ardupilot ChibiOS)… When I plug my USB cord from Holybro Pixhawk 4 Flight Controller into my PC and QGC or M/P and go to SETUP Gear Icon/Firmware and try to Update/Upgrade Firmware, my Holybro Pixhawk 4 Flight Controller Board is seen as being an Ardupilot ChibiOS, and connected to Bootloader…then it goes through the motions of erasing and copying new files.
Is there some way to "Flash Pixhawk 4 FMU-v5 Bootloader back onto the Holybro Pixhawk 4 Flight Controller Board…? Please help…! Thanks in Advance…! I’ve been to Ardupilot… they said it could be done w/QGC… ha, there are NO options in QGC to Flash the Bootloader…! =)

@Ja_L_Pa the number of issues open in our open-source projects is not a good scale to measure the quality of the software releases, the developer teams do frequent releases that are tested with known configurations before releasing.

Try flashing the latest stable release from PX4 Autopilot using QGC, you can follow the directions on the user guide https://docs.px4.io/master/en/config/firmware.html

rroche; Thanks, yeah well when one see’s 844 issues that’s a shock and very concerning…! I try the Guide… I just hope there’s some adequate directions there for me to follow… I’ll let ya know…?

You can expect a high number of GitHub issues in any open-source complex distributed system such as PX4 Autopilot, you also have to take into account we have been around for 12 years, and the permutations between the supported hardware and vehicle capabilities to only increase over time.

In short, definitely do some research on a project before you try it, I think your first instinct was correct, and asking on our forums is totally the right way to go about getting a proper answer.

Our latest stable release should work for you, and if you have any issues please post back!

rroche; Hello again… I tried what the doc said to do
(https://docs.px4.io/master/en/config/firmware,html) I do not believe that it worked because QGC displayed “found AdruPilot ChibiOS” connected to bootloader; I have screen shots showing the progress it went just fine, verified, ok…! But when I go back into the Firmware screen and plug in again… it still shows “found AdruPilot ChibiOS” connected to bootloader…? QGC shows no “Pixhawk” anything at all…! So, I came back with more info/questions…?

Please post a screenshot of the error message, and the version of QGC you are using, in case you are not using the latest stable release of QGC.