Ardupilot Firmware Not Available In QGroundControl

Hey guys, I’m trying to flash my Pixhawk 4 with the ardupilot flight stack. When I try to flash the firmware, the PX4 option works but unfortunately the ardupilot doesn’t. It just appears blank. Here is a screenshot of my screen.

There is a stable ardupilot release for the Pixhawk 4 and it works when flashing with Mission Planner on my windows laptop but not for QGroundContorl. I like using QGroundControl more and would like to flash Ardupilot with it.


1 Like

The instructions here will help.

Basically, download this:
Change the extension from .apj to .px4 and upload as a custom firmware.
I actually thought this had been fixed. Are you using latest QGroundControl?

I just checked with a CUAV v5: the daily build of QGC offered ArduPilot and flashed fine. I might have a different bootloader than you though. If you’re still having issues, let’s move the discussion to

Thank you for getting back to me. I changed the extension to .px4 and successfully uploaded it. It won’t connect when I plug the flight controller in. Yes, I am using the latest QGroundControl: v.3.4.4. Here is a picture of what I get when flashing with new firmware if it comes to any help:

OK. I just pulled down 3.4.4, and it doesn’t connect. I’d suggest using the daily build ( for now, as it seems to have this issue fixed / is working (for me at least).

Yay!!! It works now with the daily build!

Is it ok to use the daily builds or are they not stable?

Thank you so much for the help!

Thanks for the help @auturgy, out of curiosity what was the issue? this seems like something we should be testing at some level somewhere, anything we can do?

It’s addressed in detail here:
In summary: just an artifact of independent development cycles.
The ArduPilot build system uses .px4 file extensions for Nuttx builds, and .apj for ChibiOS (although they are both compatible json files for the bootloader). FMUv5 is only built with ChibiOS, so QGC wasn’t recognising them.

1 Like

I tried to flash Ardupilot on my Pixhawk 4 via the auto Firmware download with QGC daily and it didn’t work @auturgy

That’s a URL problem.
I’m guessing my bootloader has a different board ID and is recognised as a ChibiOS board, so it seeks a .apj firmware for me.
Simple fix, but I can’t look at it this week.

Should I raise an issue for you @auturgy?

Sure, just tag me on it in GitHub