Flaps falsly opening during mission flight

This weekend i was trying out the mission mode for the first time. When switching to mission mode the plane drops throttle to half and opens the flaps. However, this results in the plane flying to slow and eventually stalling. I tried upping the cruse speed from 15 to 20 m/s but that did not change the stalling.

Another problem i have is that the plane only turns with rudder during autonomous flight which in case when it is a steep turn also results in loss of control and the pilot has to take over in manual mode.

flight log: https://logs.px4.io/plot_app?log=8a93d27d-fd10-46a4-8a8b-5b16f039e781

Thank you for your help

PS: is there a way to have a minimum turn radius from one mission point to the next. The first time flying a mission, it suddenly did a 250° turn (logs: https://logs.px4.io/plot_app?log=1433cb06-9a99-4520-9fe9-fe16444fddaf)

I had a somewhat similar issue. As soon as I switched into mission flight, the flaps would deploy no matter what, on-ground, or in the air near cruise velocity. The problem was actually pretty simple, the flap channel was reversed for auto-flight. It was a bit deceptive since the flaps would behave normally in manual and altitude hold modes, but I think that maybe the flaps are not in the control loop for altitude hold mode. All I did was reverse the flap output channel and the flap input channel, now it works as intended.

I found out it was as well. Thnx for the help :slight_smile: