FC (Autopilot) Orientation is F#$kd

I’m hoping someone can restore my faith in the PX4 firmware.

I’m running PX4 version 1.13.0 on a Pixhawk 2.4.8 and a Here3 RTK (Compass and GPS).

When I set up the FC in 0 roll, pitch and yaw everything functions perfectly after calibration

When I set up the FC in 180 roll (upside down but arrow point fwd) and calibrate the compass spins and spins.

I’ve got both an internal and external compass. I’ve tried disabling one compass then the other, I’ve tried each compass individually in 180 roll or no rotation without success.

I’m hoping someone can tell me there is an issue with my parameter file and its not the firmware but I suspect the firmware. Is there an earlier version I should try?

Parameter file link: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

Also when you add yaw to the Autopilot orientation, pitch and roll inputs from the transmitter act relative to the centreline of the flight controller and not the aircraft. Another reason I’m suspecting the latest firmware has issues with the orientation.