External Compass won't calibrate


I am trying to calibrate my external compass (which is a module containing a Ublox GPS and a compass) but it won’t work.
I tried on MissionPlanner, but when the calibration bar reaches the end, the Pixhawk makes a fail sound and the calibration starts again.
Then I tried with QGroundControl and I got a more precise error :

mag(0) bad radius 601 expected 479.

I searched on the web but it seems like there is no forums talking about that issue.

What can be the problem ? Is my compass broken ?
My module is not near power cables (closest one is like 4 inch) and I am calibrating in the middle of the room with no magnetic interference.

What can I do to solve my problem ?

Thank you. Anselme

Check COMPASS_ORIENTx parameter, maybe is wrong

Thanks for the answer but I already checked that. Tried with another compass and it works better… But it’s surely a Pixhawk problem since the sphere was good.
I got a “Mag(0) bad radius 605 expected 479”…

No documentation talks about that on QGroundControl.

Thanks anyway