Can't Connect WiFi module to Pixhawk

Hi, I am trying to connect my pixhawk 2.4.8 to QGC via ESP 32 module, but have no response from QGC. I tried to follow PX4 guide, but when I tried to connect the module to Telem 1 port, FC stopped connecting via USB and kept beeping.

I have some movement on UART port and have 1 TCP connection, but QGC doesn’t see it:

My MAvLink params could help

What sort of module is that? Which instructions did you follow?


Hi, the combination of px4 documentation for esp32 and AliExpress description.
Seller guide:

IF you use PX4 firmware ,only TELEM1 can be used ,can not use TELEM2.
For Ardupilot firmware , It is recommended to use the TELEM2 port. Or find one of the available ports for the connection. For PX4 firmware , should use TELEM1 port.

Px4 Guide:

No configuration is generally required if connected to TELEM2 . The typical range is approximately 50m-200m (depending on the antenna used).

I were trying connect module to TELEM 1 as in AliExpress description and in TELEM 2 as in px4 guide, but it won’t work for both. For TELEM 1, drone stopped connecting by USB port, always beeping, and no data on UART port was sent, so I switched to TELEM 2, but also no luck.

(Aditional) I have found this part of the documentation on how to solve the connectivity issue for QGC, this is what I get from the log console. (Sorry for photo of text :))

(Solution): Sorry for that post. I have updated SER_TEL2_BAUD to 57600 same as for WiFI module and it worked. Thank you @JulianOes, and again sorry for my impatience to read everything properly/