Esc Calibration voltage divider

Hi we have a problem. When we try to calibrate our esc it says time out. Normally when we connect the battery before the calibrate it does not let us to calibrate but this time even we connect the battery first it says “connect the battery and calibration will begin” so it does not see our battery and this is not our only problem we have this either We tried to do settings our battery but we could not manege it (we have 6s lipo 3.70 empty voltage and 4.20 full voltage) we tried to calculate voltage divider and amps per volt but it does not calculate even i clicked a hundred times to calculate button but it does not do that pls help us :slight_smile:

What power module are you using? How is it connected to PX4? Does it show any voltage? What PX4 version is this? What sort of ESCs? The more concrete information, the more likely someone can help you with this.

Have a nice day we use cube orange’s power module. it’s connect with directly with power socket. it’s not a digital one.
our px4 version is 4.2.4. The ESCs are T-Motor Air40A 40 Amper ESC

Hm, that’s not a PX4 version. Could it be that you mean ArduCopter 4.2.4? In that case, you should ask in https://discuss.ardupilot.org/.