Error when Building PX4 Code - Permission Denied

Hello everyone, I’ll start by saying that I am very new to all of this, so take it easy on me.

I am working through the PX4 Devguide and have gotten to the point of building the code. The compiling on the console seemed to go just fine. Now I’m to the NuttX / Pixhawk based board section and am getting an error when running the following code in the PX4 Console.

cd Firmware
make px4fmu-v2_default

Things I have tried so far…
Installed CMake 3.8 (I thought it came with the PX4 toolkit)
Ran the PX4 console as administrator
Enabled Full Control of the entire C:\px4 directory for all users
Disabled .NET Framework 3.5 (suggested in another thread)
Tried running “make clean” before building

Any suggestions? Thank you for your time.

Try to install Jinja as explained in the error?

Yes, sorry. I did that and ended up getting further errors.

I ended up installing Ubuntu LTS on VirtualBox and followed the Linux tutorial and ran into further errors, but finally got it to build and load the project into Qt Creator.

I also had to perform this command in order for the build to succeed

sudo apt-get install lsb-core

I think several of my issues were due to installing things (CMake, GCC, etc) in the wrong directory, root vs. src vs. src/Firmware.

Indeed, I tried multiple time to do it from Windows… But simply putting my computer in dual boot solve the problem.

In Ubuntu, it simply builds without any issue (almost) ever.

Hey, I have this problem on Windows, but I can’t solved. Could you help me?