Building The Code Problem

Hi, I am new to px4 and I am trying to follow the dev guide and build the firmware.

I managed to clone the upstream repository, however I am getting an error when executing the make command:
make px4fmu-v2_default

The error I receive:
$ make px4fmu-v2_default
/bin/sh: cmake: command not found
rm: cannot remove directory `/usr/home/Julian/src/Firmware/build_px4fmu-v2_default’: Permission denied
make: *** [px4fmu-v2_default] Error 1

I tried to run the PX4 as admin since it seems to be a problem with permission, but I still got the same error. I would appreciate any help, thank you

You should install cmake and configure environment variable.
After that you can execute “cmake --version” in DOS cmd or git bash.
If there is a cmake note,you can try to rebuild your code.

why you have “Permission denied”, permission problem ,first install cmake

I installed cmake but I am not sure how to configure environment variable. I apologise but I am still new to this.

Were you able to fix this issue? I’m getting the same error.

I have installed cmake (I thought it came with the px4 toolkit, but I guess not?).
I am running the PX4 Console as an administrator.
I tried running “make clean” but also get an error: make[1]: *** No rule to make target ‘clean’. Stop.
I have disabled .NET Framework 3.5 (includes .NET 2.0 and 3.0) per recommendation on another thread
I am using Windows 10.

I’ve got the same problem on Windows 7. I can confirm that the px4 console can find cmake.

same problem any ideas? how do you use cmake?

it works if you build in bash

How to build in bash sir?

I am a newbie in this field…

Could you solved this problem on Windows?