Gazebo wont open, please help

#1

Hello I am new here. I am having trouble settingup SITL and running. When I make, it gets stuck here. I had to force close after this.

When I run: sudo make px4_sitl_default gazebo
`(base) bigfoot@bigfoot-MacBookPro:~/src/Firmware$ sudo make px4_sitl_default gazebo
[2/6] Performing configure step for ‘sitl_gazebo’
– install-prefix: /usr/local
– Using C++17 compiler
– Boost version: 1.65.1
– Found the following Boost libraries:
– system
– thread
– filesystem
– chrono
– date_time
– atomic
– Boost version: 1.65.1
– Found the following Boost libraries:
– thread
– system
– filesystem
– program_options
– regex
– iostreams
– date_time
– chrono
– atomic
– Found Protobuf: /usr/lib/x86_64-linux-gnu/libprotobuf.so;-lpthread (found version “3.0.0”)
– Boost version: 1.65.1
– Looking for OGRE…
– Found Ogre Ghadamon (1.9.0)
– Looking for OGRE_Paging…
– Found OGRE_Paging: optimized;/usr/lib/x86_64-linux-gnu/libOgrePaging.so;debug;/usr/lib/x86_64-linux-gnu/libOgrePaging.so
– Looking for OGRE_Terrain…
– Found OGRE_Terrain: optimized;/usr/lib/x86_64-linux-gnu/libOgreTerrain.so;debug;/usr/lib/x86_64-linux-gnu/libOgreTerrain.so
– Looking for OGRE_Property…
– Found OGRE_Property: optimized;/usr/lib/x86_64-linux-gnu/libOgreProperty.so;debug;/usr/lib/x86_64-linux-gnu/libOgreProperty.so
– Looking for OGRE_RTShaderSystem…
– Found OGRE_RTShaderSystem: optimized;/usr/lib/x86_64-linux-gnu/libOgreRTShaderSystem.so;debug;/usr/lib/x86_64-linux-gnu/libOgreRTShaderSystem.so
– Looking for OGRE_Volume…
– Found OGRE_Volume: optimized;/usr/lib/x86_64-linux-gnu/libOgreVolume.so;debug;/usr/lib/x86_64-linux-gnu/libOgreVolume.so
– Looking for OGRE_Overlay…
– Found OGRE_Overlay: optimized;/usr/lib/x86_64-linux-gnu/libOgreOverlay.so;debug;/usr/lib/x86_64-linux-gnu/libOgreOverlay.so
– Found Protobuf: /usr/lib/x86_64-linux-gnu/libprotobuf.so;-lpthread;-lpthread (found suitable version “3.0.0”, minimum required is “2.3.0”)
– Checking for module ‘uuid’
– Found uuid, version 2.31.1
– Checking for module ‘tinyxml2’
– Found tinyxml2, version 6.0.0
– Looking for dlfcn.h - found
– Looking for libdl - found
– FreeImage.pc not found, we will search for FreeImage_INCLUDE_DIRS and FreeImage_LIBRARIES
– Checking for module ‘gts’
– Found gts, version 0.7.6
– Checking for module ‘libswscale’
– Found libswscale, version 4.8.100
– Checking for module ‘libavdevice >= 56.4.100’
– Found libavdevice , version 57.10.100
– Checking for module ‘libavformat’
– Found libavformat, version 57.83.100
– Checking for module ‘libavcodec’
– Found libavcodec, version 57.107.100
– Checking for module ‘libavutil’
– Found libavutil, version 55.78.100
– Checking for module ‘jsoncpp’
– Found jsoncpp, version 1.7.4
– Checking for module ‘yaml-0.1’
– Found yaml-0.1, version 0.1.7
– Checking for module ‘libzip’
– Found libzip, version 1.1.2
– Building klt_feature_tracker without catkin
– Building OpticalFlow with OpenCV
– catkin DISABLED
– Found Protobuf: /usr/lib/x86_64-linux-gnu/libprotobuf.so;-lpthread;-lpthread;-lpthread (found version “3.0.0”)
Gazebo version: 9.8
– Configuring done
– Generating done
– Build files have been written to: /home/bigfoot/src/Firmware/build/px4_sitl_default/build_gazebo
[3/6] Performing build step for ‘sitl_gazebo’
ninja: no work to do.
[5/6] cd /home/bigfoot/src/Firmware/bu…ot/src/Firmware/build/px4_sitl_default
SITL ARGS
sitl_bin: /home/bigfoot/src/Firmware/build/px4_sitl_default/bin/px4
debugger: none
program: gazebo
model: none
src_path: /home/bigfoot/src/Firmware
build_path: /home/bigfoot/src/Firmware/build/px4_sitl_default
empty model, setting iris as default
GAZEBO_PLUGIN_PATH :/home/bigfoot/src/Firmware/build/px4_sitl_default/build_gazebo
GAZEBO_MODEL_PATH :/home/bigfoot/src/Firmware/Tools/sitl_gazebo/models
LD_LIBRARY_PATH :/home/bigfoot/src/Firmware/build/px4_sitl_default/build_gazebo
Gazebo multi-robot simulator, version 9.8.0
Copyright © 2012 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

[Err] [Master.cc:96] EXCEPTION: Unable to start server[bind: Address already in use]. There is probably another Gazebo process running.

[Err] [Master.cc:96] EXCEPTION: Unable to start server[bind: Address already in use]. There is probably another Gazebo process running.

SITL COMMAND: “/home/bigfoot/src/Firmware/build/px4_sitl_default/bin/px4” “/home/bigfoot/src/Firmware”/ROMFS/px4fmu_common -s etc/init.d-posix/rcS -t “/home/bigfoot/src/Firmware”/test_data
INFO [px4] Creating symlink /home/bigfoot/src/Firmware/ROMFS/px4fmu_common -> /home/bigfoot/src/Firmware/build/px4_sitl_default/tmp/rootfs/etc


| ___ \ \ \ / / / |
| |/ / \ V / / /| |
| __/ / \ / /
| |
| | / /^\ \ ___ |
_| / / |_/

px4 starting.

INFO [px4] Calling startup script: /bin/sh etc/init.d-posix/rcS 0
SYS_AUTOSTART: curr: 0 -> new: 10016
BAT_N_CELLS: curr: 0 -> new: 3
CAL_ACC0_ID: curr: 0 -> new: 1376264
CAL_ACC1_ID: curr: 0 -> new: 1310728
CAL_ACC_PRIME: curr: 0 -> new: 1376264
CAL_GYRO0_ID: curr: 0 -> new: 2293768
CAL_GYRO_PRIME: curr: 0 -> new: 2293768
CAL_MAG0_ID: curr: 0 -> new: 196616
CAL_MAG_PRIME: curr: 0 -> new: 196616
COM_DISARM_LAND: curr: -1.0000 -> new: 0.1000
COM_OBL_ACT: curr: 0 -> new: 2
COM_OF_LOSS_T: curr: 0.0000 -> new: 5.0000
COM_RC_IN_MODE: curr: 0 -> new: 1
EKF2_ANGERR_INIT: curr: 0.1000 -> new: 0.0100
EKF2_GBIAS_INIT: curr: 0.1000 -> new: 0.0100
MC_PITCH_P: curr: 6.5000 -> new: 6.0000
MC_PITCHRATE_P: curr: 0.1500 -> new: 0.2000
MC_ROLL_P: curr: 6.5000 -> new: 6.0000
MC_ROLLRATE_P: curr: 0.1500 -> new: 0.2000
MPC_HOLD_MAX_Z: curr: 0.6000 -> new: 2.0000
MPC_Z_VEL_I: curr: 0.0200 -> new: 0.1500
MPC_Z_VEL_P: curr: 0.2000 -> new: 0.6000
MPC_XY_P: curr: 0.9500 -> new: 0.8000
MPC_XY_VEL_P: curr: 0.0900 -> new: 0.2000
MPC_XY_VEL_D: curr: 0.0100 -> new: 0.0160
MPC_JERK_MIN: curr: 8.0000 -> new: 10.0000
MPC_ACC_HOR_MAX: curr: 10.0000 -> new: 3.0000
NAV_ACC_RAD: curr: 10.0000 -> new: 2.0000
NAV_DLL_ACT: curr: 0 -> new: 2
RTL_DESCEND_ALT: curr: 30.0000 -> new: 5.0000
RTL_LAND_DELAY: curr: -1.0000 -> new: 5.0000
RTL_RETURN_ALT: curr: 60.0000 -> new: 30.0000
SDLOG_MODE: curr: 0 -> new: 1
SDLOG_PROFILE: curr: 3 -> new: 131
SDLOG_DIRS_MAX: curr: 0 -> new: 7
SENS_BOARD_X_OFF: curr: 0.0000 -> new: 0.0000
Gazebo multi-robot simulator, version 9.8.0
Copyright © 2012 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

SENS_DPRES_OFF: curr: 0.0000 -> new: 0.0010
[Msg] Waiting for master.
[Msg] Connected to gazebo master @ http://127.0.0.1:11345
[Msg] Publicized address: 192.168.0.224

  • RTL_DESCEND_ALT: curr: 5.0000 -> new: 10.0000
  • RTL_LAND_DELAY: curr: 5.0000 -> new: 0.0000
    PWM_MAX: curr: 2000 -> new: 1950
    PWM_MIN: curr: 1000 -> new: 1075
    INFO [dataman] Unknown restart, data manager file ‘./dataman’ size is 11798680 bytes
    INFO [simulator] Waiting for simulator to connect on TCP port 4560
    [Wrn] [GuiIface.cc:122] QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-root’
    [Wrn] [Publisher.cc:141] Queue limit reached for topic /gazebo/default/user_camera/pose, deleting message. This warning is printed only once.

`