Drotek DP0503 RTK GNSS (XL M8P) yaw estimation errors cause failsafe no global position

Hello everyone!

We have two drones: FMUv5 + Pixhawk 4 Neo-M8N GPS and FMUv2 + Drotek DP0503. Both running on PX4 1.8.2.

And everything good with the first setting, but the drone with Drotek doesn’t flight good in Position Mode or in Mission Mode. It’s started to toilet bowl or even went to a failsafe “no global position”.
When I tried to investigate it, I’ve found that even if I rotate the copter with Drotek GPS on 180 deg it doesn’t estimate this rotation right. It estimates the rotation around 150 deg instead of 180 deg. Also it have some kind of the slowly changing estimations: when I just stopped the rotation it estimated yaw around 280 deg and after several seconds it slowly came to 252 deg.

I’ve made experiment of rotation copters on the ground using laser level as a reference, to check rotation on 180 deg:

Logs from drone with Drotek:
Log from drone with Pixhawk 4 GPS:

It’s easy to noticed that Drotek’s compass has this kind of problems described above.

To get your more information:

  • I’ve tried on 2 different Drotek’s modules DP0503
  • I’ve calibrated magnetometer several times, while debugging this issue

Can someone help me, what can I do to fix this yaw estimation errors?


Hi @szobov ,
It could be that the mag is subject to soft iron effects. Can you place the Drotek mag where you placed the Pixhawk4 one and repeat the experiment?
On the drotek one, the GPS reports more jamming that on the other one, are you running the exact same things and components on both setups? (especially camera, and companion computer)

My understanding is that v1.8.2 on a FMUv2 Pixhawk may not have enough power or software capability to run an RTK GPS module. I’d try swapping the DP0503 for the ublox N8M, matching it with the more powerful controller. And if you upgrade to PX4 v1.9.2 you will have a lot more capability at your disposal because this newer version has much better ability to use higher performing sensors.

Good luck, Joe

Hello everyone!
Thank you for responding!
@bresch all components are same, except gps and flight controllers. We tried to place drone as you say, and there is no effect.
@Joseph_Marrone We tried to upgrade to PX4 v1.9.2 and there is no effect too.

We plan to use a ublox ZED-F9P GPS/RTK receiver very soon, and will be using PX4 1.9.2 for the testing. Your experience gives me a heads-up in case we run into the same issues.


I also want to add some information:
I’ve made several experiments:
FMUv2 + Drotek DP0503

  1. PX4 v1.8.2: problems that where described by @szobov
  2. PX4 v1.9.2: I can’t turn on lis3mdl compass with error: nsh: lis3mdl: command not found
  3. PX4 master (https://github.com/PX4/Firmware/commit/2fcddd9b8d36b636e84f7e6c57f13904af79e430): I can’t turn on lis3mdl compass too. The error is the same: nsh: lis3mdl: command not found

@bresch lis3mdl is not supported for last release of firmware for FMU_v2, isn’t it? Or do I do something wrong?

FMUv3 + Drotek DP0503

  1. PX4 v1.8.2: problems that where described by @szobov
  2. PX4 v1.9.2: lis3mdl start, but problems that where described by @szobov

Hi, I am working on a same project: a localisation and guidance using Drotek DP0503 RTK XL M8P and i want to use the integrated compass LIS3MDL for guidance.
I have an Arduino Uno, is it possible to use it as an autopilot?
And can you please send me the configuration of the DP0503 to be sure that’s right?