Drone not stable in flight

HI all, I’m kinda new to this platform and I made my first test flight yesterday with a Pixhawk 4 mounted on a custom frame, (2.2kg takeoff weight, 570mm base wheel). I used the Holybro s500 frame in the QGroundControl setup and used default gains. During my first flight I noticed low frequency oscillations and the drone was very unstable, it has been very hard to land it successfully. I guess I have to tune the PID controllers but I’m a noob with PX4 and I wonder if someone could take a look at the flight video and suggest a correct procedure in order to tune my quad.
Thank you in advance and any recommendation is well accepted :smiley:

Video of the flight:

Hi @Matte_Lanni !
Have you read this document?
After seeing the video, I would say that the overall rate gains are too high. Reducing the MC_ROLLRATE_K and the MC_PITCHRATE_K should increase stability: lowering them from 1.0 to 0.6 should stop the oscillations; then you can play around with this parameter to have the desired response/stability ratio. (The K gains are not in the document but they basically lower P, I and D at the same time)

Have fun!

1 Like

Hi @bresch thank you very much for your help!
Yes I read the document but honestly I found it a bit confusing because this is my first experience and I have a lot of things to learn yet :sweat_smile:
I will proceed following your suggestion, thank you very much :smiley:

Hello Mr. @bresch I ask for your help again, or anybody who can suggest how to solve the problem.
I followed your advices, read the document again and modified the MC_ROLLRATE_K and MC_PITCHRATE_K parameters, and here is what I obtained with my quad:

MC_ROLLRATE_K and MC_PITCHRATE_K = 0.6

MC_ROLLRATE_K and MC_PITCHRATE_K = 0.4

MC_ROLLRATE_K and MC_PITCHRATE_K = 0.3

I would have proceeded bringing the two parameters both to 0.35 because I think I was getting some results but suddenly after the last crash I burnt an ESC and I’ll have to replace it. In the while I wondered if someone could tell me if my approach was correct or not and any other suggestion is well accepted :sweat_smile:
Thank you in advance

Hi @Matte_Lanni
I’m not really an PID expert but I was able to achieve stable flight on my S500 by increasing MC_ROLLRATE_D MC_PITCHRATE_D to 0.40. Let me know it it works for you as well.