Drone flips over upon takeoff

My drone flips over when increasing throttle.

I use Pixhawk2 /firmware version 1.8.0 /QGC

Currently I tried

  1. Checking motor direction
  2. Checking propeller direction
  3. Changing board
  4. Changing cube
  5. Changing ESC
  6. Checking for wrong line connection
  7. Calibration of all sensors

Below is an analysis of 4 servo outputs. And at the red lines I…
1: Increase throttle
2: Decrease throttle
3: Increase throttle
4: Decrease throttle

I noticed that the servo 3 constantly decreases and servo 4 constantly increases when even if I didn’t change the throttle.
I think I tried everything I can think of. If anyone has some clues or answers please help. Thanks!

Had the same issue, you might want to take a look here

Thanks for the link. Tried it, but no success. First, there was no parameter MOT_PWN_MAX or MOT_PWN_MIN. I couldn’t find it in the QGC. By the way I’m using px4 firmware ver 1.8.0 stable. Instead I changed PWM_MIN and PWM_MAX to 1000 and 2000 respectively. Then calibrate ESC. Still the same.

Now QGC is telling me that some parameters are missing. MC_ROLL_TC , MC_PITCH_TC etc.

Yes you are correct, I flashed ArduPilot instead of PX4.

Any way, one observation that I made an hour ago where I went to AutoTune my quad was that on first attempt, it showed me the same issue of trying to flip!, I had my laptop with me so I calibrated level only!!! and the quad lifted like never before.
So, I believe the quad must be truly leveled before takeoff. I am now sure that this was my whole problem.

Since you use QGC, You can send it the level command from your phone or something?

Just to elaborate a little my understanding (I don’t know much), any one please correct me if I’m wrong: since we fly initially in Stabilized mode it basically means that all signals to motors are sent by the FC based on what it “thinks” the state of the quad is in the X,Y,Z space and I think that the issue with the RCOut 3 low, is the same as mine was RCOut 3 flat line - so in my opinion your FC thinks that it doesn’t need to raise the RPM on motor 3.
All the above is only if I figured it out correctly :slight_smile:.


@bullgom0213 Were you able to fix your issue? i have exactly the same issue and my log graphs practically look the same too when you increase throttle. Two motors spin way faster than the other two so the drone tries to flip.