Disarming Denied. Motors lock into high speed when QGC emergency disarm slider is used

Hello all,

This is my first drone ever! I have a pixhawk 2.4.8 connected to my laptop via SDR 915 MHz Tx/Rx radios. I am controlling the drone via logitech gamepad. I am able to arm the vehicle, change flight modes, and increase/decrease throttle reliably. However, I am not able to safely turn off the motors (No props are attached yet :slight_smile: ). In fact, my disarm command is being denied. So far the only way to get the motors off after arming and spinning them, is to physically run up and unplug the power. I am able to disarm the vehicle using the QGC emergency disarm slider AND the pixhawk safety switch, but they are useless!!! The motors lock into a high speed after disarming which is the opposite of disarming lol.

I do not have a gps attached or any other sensor for the vehicle to determine if it has landed so I do no know why the system wants to deny me safety in regards to simply turning off motors.

Please help. This is the last step before I can take flight!

In which flight mode are you trying this? The thing is that PX4 needs to detect that it is landed before you are allowed to disarm. Usually when you hold throttle down for a while the motor speeds will go back down to idle and at this point disarming is possible.

I have tried disarming in acro and stabilize flight mode and yes, the system does say “vehicle not landed, disarm denied”. However when i press the button for disarm on my logitech controller, Im sending a low enough throttle to where the motors arent spinning. I even wait about 10 seconds in that state and nothing special happens. Additionally, no propellers are attached during these tests so the vehicle is always physically landed.

There is an issue with throttle actually. Im using the “center stick is zero throttle” feature but its behaving more like the MAX negative throttle in the center, zero thottle is halfway up, and full throttle is all the way up. Is this normal? After arming, to begin spinning the motors I must move the stick about halfway up from the center and then the esc beeps once before spinning the motor. Sorry if this is an overload

Arducopter behaves the same way with me too


So after some more playing around, I set the joystick control to “full down stick is zero throttle” in qgroundcontrol. This gave more ideal motor control compared to center stick and I was able to disarm the vehicle at zero throttle position.

HOWEVER, the motors don’t turn off when disarmed. They still spin at a high speed. I will have 8 inch propellers on the copter so I need the motors to completely stop when disarmed so I can safely handle the vehicle. Please help, I am so eager to fly lol.

Thank you for your time

And they don’t stop? :astonished:
And is it really disarmed? Does QGC show disarmed?

It’s crazy right! No they don’t stop and yes qgc shows disarmed. It’s like they’re spinning at max too

Ok that’s not good. What ESCs are you using? And when that happens can you do a px4io status in mavlink shell?