Data in NSH Terminal garbled

I am using PX4 Firmware version 1.8.0. I have built the firmware and uploaded it to Pixhawk 1 board. I tried to login to the NSH Terminal over USB. But I am getting garbled junk data. I tried reconnecting the board but it does not seem to work out. Any ideas ?

P.S. This worked with PX4 Firmware version 1.6.5 without issues. I was able to login to the NSH Terminal when I had 1.6.5 all the time. The problem started coming after I migrated to v1.8.0

You’re seeing the mavlink output. Open QGC and use the mavlink console if you need terminal access.

Can’t I use just USB connection to access terminal without using QGC ?

Without changing the firmware, no.
But you can also use the debug serial port:

Thanks for the suggestion,
I now used an FTDI connector to connect the S5 of pixhawk 1. I can now see the terminal. I can also see some initial debug statements. However I am unable to type any commands on the terminal. It is as if it is stuck somewhere. I have not changed anything in Firmware.

Any idea on how to resolve this ?

You also mentioned without changing firmware, I cannot use the USB connection to login to the firmware. Which firmware do I need to use for that ?

I believe if you have The pixhawk’s RX (your PC’s TX) connected right you should be able to send characters to the device. At least that works on a Pixracer I have laying around.

You would have to change the firmware to not start a mavlink instance on the USB port and potentially also start a console on it, not sure.

1 Like

Thanks , that actually turned out to be true. I had a rudimentary connection for FTDI and when I tightened the Tx connection , I got the control back.