PixFalcon Console or Shell


I have been trying to access a shell or console on a PixFalcon. This is a brand new PixFalcon. I have connected to: USB port, Telem port and GPS port. They all appear to be running at 57600 baud 8N1. However, they all have non-alphanumeric characters, non-printable characters and short segments of readable text. None seem to respond to input of any sort. I have also tried to use QGC and MissionPlanner to connect to it. They will both connect in the normal fashion but neither seem to provide a way into a shell. QGC MAVLink console has a field for command entry but it does not respond to any commands I enter. I looked at the SD card but it didn’t seem to have anything useful on it.

I feel like I am missing something fundamental but can not make anything work.

USB Output

TELEM Output

GPS Output

On USB and Telem you are looking at binary MAVLink traffic which means the data is serialized according to the MAVLink protocol. On the GPS port you are probably looking at binary UBX traffic which is what is used to communicate with uBlox GPSs.

What are you actually trying to achieve? If you need the NuttShell (nsh>) console, check these docs about system console.

Generally, I am curious and am trying to look at the file system. I tried the MAVLink shell in QGC but it appeared to be unresponsive.
I can try the non-QGC MAVLink shell but I have not downloaded any source code nor have what appears to be a Linux platform.
I read through the system console documentation many times but it all relies on finding the console port which I apparently have not found. Perhaps it is not exposed on the PixFalcon due to the limited resources on that hardware.

Ok, if you want to look at the (virtual) file system you can do that using mavlink_shell. If you have a working mavlink connection in QGC, it “should” actually just work. Have you tried updating the PX4 firmware in QGC?