CubeOrange+ Here3+ module CAN communication problem

Hi Community.
I developed my px4 autopilot software. I have the stabiled version. I use cubeorange with gnss module here3+. My software is working fine. I can get gnss data correctly. But i started cubeorange+. I dont connect the here3+ module. I got the up-to-date cubeorange+ board of Px4 and fixed it properly. But I can’t connect to CAN line. I tried with I2C and it worked. I tried the same software with cubeorange, it worked again, but it doesn’t work in cubeorange+. I have conveyed the log message that I received an error in the picture. What does the error it gives in the uavcan part here mean? I’ll be happy if you can help me.

I fixed that last error when I defined a nodeID myself and ran it. But this time there were other errors. My GNSS Module is working fine. There is no hardware error. The cubeorange and cubeorange+ sections under the cubepilot folder on the Board are almost exactly the same. What can cause these errors? Why can’t I communicate over CAN? I would be glad if you share your idea.

Hi @NorMinyLaus! Can you tell me what version you’re flashing on the Orange+? I assume it’s something based on top of v1.14 or main?

From the output it looks like something fails at the UAVCAN node init.

I will try to reproduce this. Can you tell me which CAN port you’re using? Or is it on both? And if you could do a param export in QGC and attach it here, that might also help to narrow it down.

1 Like

Hi @JulianOes !,

Actually, I’m using version 1.12.3. I’m using CAN 1 port, but I also tried CAN 2 without any changes. I’m sure the issue is software-related. When I download and install the latest PX4 autopilot software, I don’t encounter any problems. However, I need to resolve this issue with my own version. When I test the same software with CubeOrange, I don’t have any problems. It connects seamlessly to the GNSS Here3+ module. But after the release of CubeOrangePlus, I incorporated the latest PX4 versions into the ‘boards->cubepilot->cubeorangeplus’ section and made the necessary adjustments to my code. There aren’t many changes from the CubeOrange section. However, when I compile it, I’m unable to communicate with the GNSS through this CAN bus. There are no issues when I try using I2C.

I added to param datas.
paramdatas.pdf (13.4 KB)

I am eagerly awaiting your response. Thank you.

Oh, so you’re using this backport?

I will try to reproduce with this backport then…

1 Like

Thank you for taking the time. I have resolved the issue. While preparing the compilation files for Orange Plus, I encountered a few minor errors, but I managed to solve the problem by referring to the changes made for Orange Plus in versions 1.4.0 beta-1 and beta-2. Still, thank you

1 Like