Cube Orange PX4 installation fails

Hi
We have been trying to install PX4 (1.12.1) into 2 Cube Oranges (from different production batches, purchased 2 years apart), and failing. We have tried using the latest QGC and MP. It looks like the installation is successful, but when it restarts, the Device Manager (in windows 10) reports two ports, a Bootloader port (and it does work as bootloader for flashing new firmware) and a Mavlink port with an “!” in a yellow triangle. The Mavlink port information in Windows report a Code 10 error, “does not start”. And neither MP or QGC manages to connect. I am also unable to connect using TELEM1 port, which I would assume by default should be active (it is on Ardupilot after flashing with that, without any configuration).
We have tried using 2 different Windows 10 laptops, with slightly different hardware setups and time of installation of software, one was clean and started with a clean install of QGC to begin with.

It might be a driver problem, but we do get Black cube with PX4 to connect to the laptop, so we are not convinced it is that, but are wondering if it might be some problem preventing proper startup of the software onboard. Any help or suggestions would be most welcome, since the Black cube is no longer in stock almost anywhere.

Best regards
Torbjørn

Hi Torbjon,

The drivers problems with the Cube Orange specifictly, could be a nightmare. Is not strange to being able to connect to a Cube Black but not to a Cube Orange.

I suggest you the next workaround that has worked for me many times:

  1. Uninstall QGC.
  2. From Device Manager unistall both Cube orange devices (with the orange plugged). After that unplugg the Cube.
  3. Enter to Mission Planer (in case you have it installated). Press Ctrl+F and select “clean drivers”. Unistall Mission Planner.
  4. Go to UAV drivers installation folder (usually within Program Files) and execute “cleandrivers”.
  5. From Control Panel, unistall “UAV Drivers” application and all the HEX microsoft drivers.
  6. Restart computer.
  7. Install Mission Planner. When you connect now the Cube Orange you will see this within Device Manager.
    imagen
  8. Install a stable version of QGC. Important: Don’t install again UAV drivers (press cancell in that step).

In case that solution didn’t work, you will need a deep clean of your drivers.
For that, first of all clean all the drivers within the device manager of old cube/hex devices following this link:

After that, clean the cube/hex drivers using a tool like this one (trial version):

After that, reinstall Mission Planner and QGC again.

Hi all,

Wanted to tag onto this conversation to say that we are experiencing the same thing, even after going through the suggestions for cleaning out the drivers.

To add a bit more details here : I’m actually suspicious that this isn’t a driver / connectivity issue and more of an issue with either the installation itself or with the booting of the device. I’ve actually tried installing the most recent stable release of the cubepilot_orange firmware through 3 methods :

  • on windows, using QGC
  • on windoes, using Mission Planner (custom firmware file installation)
  • on linux, building from source (on the release tag) and installing through the command line

The weird thing is, all 3 of these methods actually claim to be succeeding (and the output is consistent with my successful installs in the past). However, after the install, on powering up the cube, only the orange LED lights up, there is no green LED heartbeat as is normally present after a successful install. That’s leading me to believe there’s something wrong with the firmware file actually booting on the device as opposed to this simply being a connection issue with windows drivers (I’ve also tried to connect to it via an ubuntu mavlink driver with no luck).

Anyone have more ideas?

Thanks,
Isaac

Hi
That aligns with my suspicions as well since with the Black I can connect with a USB-TTL dongle to Telem1 port directly (eliminating the Cube driver issue) with both QGC and Mission Planner, while I get no Mavlink over Telem1 from Orange. I would expect at least this config being identical regardless of drivers and physical hardware PX4 runs on.

As Isaac describes, only orange LED lights up, no heartbeat.

Thanks,
Torbjørn

@THouge I’m actively chatting and testing some stuff out with the devs over on the slack channel, but I unexpectedly came across a possible temporary solution until a patch gets merged in :

Try attaching the safety button (comes in the initial kit, attaches to GPS 1) and holding that down during power-on. I was able to get my system to boot up by doing that for the first boot. After that, it boots normally, even if the button is not attached.

I’d hold off from marking this as the “answer” until I get back having concluded testing the new software / that new software makes it into a stable release, but wanted to let you know in case it gets you un-stuck.

Isaac

Thanks @Isaac_Olson

This appears to work (had to do a couple attempts, and experienced several variants of flashing and steady lights on the Pixhawk and the switch, one apparently due to a failed firmware installation). I have only tested with a new Orange I had laying around, not the one in the actual UAV, but this is one step forward. Looking forward to how this translates into a patch.

Torbjorn

Also related : Cube Orange constantly beeps programming tone after PX4 stable firmware flashed - #7 by jacain - Cube Autopilot - Cubepilot

I think we’re still waiting on the branch to get released, but some additional information that might be relevant.