Copter won't auto takeoff

Hey guys,

so we got this strage problem, where the drone won’t do an automated takeoff. It doesn’t matter if we do it via the rc by engaging takeoff-mode or if we do it with QGround control.
Sometimes it works, but most of the times it won’t. We have seen that on two failed takeoffs the motors start to raise the rpm extremly slow before the auto_preflight_disarm disarmed the motors.

We did a custom build to enable RTPS, but the time this issue occures, there were no RTPS-Commands send.

Maybe some of you guys could give us a hint on that…
Here is a sample logfile one of the failed takeoffs.

Thanks in advance and kind regards


There is no thrust setpoint visible in the log, but I see that there is a mode change from Position to Auto_Takeoff after the vehicle is armed.
How did you trigger the takeoff? Just hit on the “Takeoff” button in QGC? You don’t need to arm the vehicle for that, the “Takeoff” command takes care of that.

@sfuhrer Thanks for your reply!
Thats right. In this case, we arm the compter and send a MAV_CMD to set the takeoff mode.
But we also did some experiments with setting the mode via RC. And get the same behaviour (no takeoff).

Could this lead to problems if we arm the copter before entering the takeoff mode?

We have had some flights where the takeoff worked, exactly as we did it here. It seems to work randomly sometimes but most of the times it won’t work at all…

As you point out there are no setpoints (except the trajectory_setpoint) beeing published. This is what i have seen in all logs with the failed takeoff. When the takeoff works, i noticed that all setpoints (attitude, local pos, rate) are peeing published as they should…

I hope not, but I never tried. Just out of curiosity, why do you need to arm it before you trigger Takeoff?

The acceleration setpoint is constantly at 100 m/s/s, I think this is usually done to make sure that the vehicle is pushed into the ground when in landed state. So looks like a bug in the logic.

Are you flying with an official PX4 release or something custom? What’s it based on if so?

Hey @sfuhrer, sorry for my late response, I was on vacation :slight_smile:

We need to arm the copter, before engaging the Takeoff-Mode via MAV-Link because otherwise the copter won’t arm itself.

In this flight, we used a custom PX4 1.13 build with enabled RTPS. But we have seen this issue aswell with an other copter that is currently on PX4 1.13 stable.

I think it could be releted to this issue, so i build an image with this fix in it, based on PX4 1.13. We can observe the exact same issue with the acceptance radius becomming nearly 0 on all our logs with the failed takeoff.
Aswell as in the Log mentioned in my first post:

I will test the image tomorrow and let you know if this worked.

1 Like

Hey all, hey @sfuhrer,

today we tested the fix mentioned in the issue here: VTOL takeoff problem hotfix by MaEtUgR · Pull Request #20171 · PX4/PX4-Autopilot · GitHub

And it worked! We did 50 takeoffs and every takeoff worked as it should! :slight_smile:

Hope this helps somebody else. I will also report this back to the PX4 dev-team.