Can not arm my Generic Ground Vehicle

Hi all,
I can not arm my Generic Ground Vehicle.
The summary of the settings for my vehicle are in the first capture as follows. All of the calibrations are OK.
But QGC reported Preflight Fail:Compass #0 uncalibrated in the second capture as follows.
Is there any mistakes? How can I fix it?
How can I get rid of Compass calibration or just skip to armed state?

Thanks & Best Regards!

Have you tried doing the mag calibration again to be sure?

Hi Julian,
I have completed the mag calibration many times.
It always can success as the capture 1.
Now I give it up and just want to skip Compass Calibration and enter armed state directly.
Could you please give me some suggestions about that?
Thanks a lot!

Have you tried using another Radio Receiver, I’ve had some similar issues with Futaba receivers.

Hi gdu,
Yes, I have tried using another Radio Receiver.
Both those Radio Receivers had ever successed to arm my Generic Ground Vehicle.
Now they both can not.
Thank for your reply!

Could you open the checklist and show us a screenshot?

1 Like

Where is the checklist?

You need to check “use preflight checklist” in general parameters.
Then you’ll see a checklist of things to do before arming.

Hi gdu,
Thank you very much.
There are so many issue. I’ll do the things on the checklist firstly.

Thanks & Best Regards!