[BUG] High accelerometer bias. SITL Gazebo

#1

Hello,

I am receiving high accelerometer bias after resetting the iris model.

Also I am receiving the same error when I change the iris model to the iris optical flow model. Even before flying
the iris_optical_flow model for the first time.

Do you have any ideas?? How to eliminate the error?? Or why I am receiving this error??

PS: rebooting the quadcopter using the reboot function does not change any thing

Please help,

Thanks.

#2

Hey,

I am getting the same error. When I start my machine and start my simulations for the first time I don’t get this error. When I close my simulations and start again, I start getting this same error message as you do.

I got rid of this error by disabling the accelerometer tests in preflightcheck.cpp. I think these tests are not that relevant to have in a simulator environment. Have you found any other solutions for this issue? :slight_smile:

#3

I did not find another solution for the iris quadcopter with the optical flow,
However, we can increase the allowed limit for the bias inside the source code of PX4.
The parameter called
COM_ARM_EKF_AB

look here for more details:

Please tell me if it going to work with the optical flow or not

#4

How you disable the accelerometer tests in preflightcheck.cpp?