[BUG] High Accelerometer bias EKF2. SITL Gazebo

#1

Here is the sensors status when the quadcopter fails to arm due to high sensors bias

pxh> sensors status
INFO  [sensors] gyro status:
INFO  [ecl/validation] validator: best: 0, prev best: 0, failsafe: NO (0 events)
INFO  [ecl/validation] sensor #0, prio: 100, state: OK
INFO  [ecl/validation]  val:   0.0058, lp:  -0.0017 mean dev:  -0.0001 RMS:   0.0060 conf:   1.0000
INFO  [ecl/validation]  val:  -0.0109, lp:  -0.0064 mean dev:  -0.0001 RMS:   0.0059 conf:   1.0000
INFO  [ecl/validation]  val:   0.0014, lp:   0.0003 mean dev:  -0.0001 RMS:   0.0059 conf:   1.0000
INFO  [sensors] accel status:
INFO  [ecl/validation] validator: best: 0, prev best: 0, failsafe: NO (0 events)
INFO  [ecl/validation] sensor #0, prio: 100, state: OK
INFO  [ecl/validation]  val:  -0.2835, lp:  -0.2631 mean dev:   0.0015 RMS:   0.0698 conf:   1.0000
INFO  [ecl/validation]  val:   0.1161, lp:   0.1588 mean dev:  -0.0023 RMS:   0.0705 conf:   1.0000
INFO  [ecl/validation]  val:  -9.7743, lp:  -9.8268 mean dev:   0.0019 RMS:   0.0706 conf:   1.0000
INFO  [ecl/validation] sensor #1, prio: 75, state: OK
INFO  [ecl/validation]  val:  -0.3004, lp:  -0.2601 mean dev:   0.0028 RMS:   0.0901 conf:   1.0000
INFO  [ecl/validation]  val:   0.0717, lp:   0.1565 mean dev:   0.0009 RMS:   0.0914 conf:   1.0000
INFO  [ecl/validation]  val:  -9.7855, lp:  -9.8212 mean dev:   0.0049 RMS:   0.0920 conf:   1.0000
INFO  [sensors] mag status:
INFO  [ecl/validation] validator: best: 0, prev best: 0, failsafe: NO (0 events)
INFO  [ecl/validation] sensor #0, prio: 50, state: OK
INFO  [ecl/validation]  val:   0.1970, lp:   0.1974 mean dev:  -0.0007 RMS:   0.0099 conf:   1.0000
INFO  [ecl/validation]  val:  -0.0864, lp:  -0.0825 mean dev:  -0.0005 RMS:   0.0102 conf:   1.0000
INFO  [ecl/validation]  val:  -0.4293, lp:  -0.4289 mean dev:  -0.0008 RMS:   0.0105 conf:   1.0000
INFO  [sensors] baro status:
INFO  [ecl/validation] validator: best: 0, prev best: 0, failsafe: NO (0 events)
INFO  [ecl/validation] sensor #0, prio: 75, state: OK
INFO  [ecl/validation]  val: 955.9312, lp: 955.9419 mean dev:  -0.0003 RMS:   0.0107 conf:   1.0000
INFO  [ecl/validation]  val:  32.0000, lp:  32.0000 mean dev:   0.0000 RMS:   0.0000 conf:   1.0000
INFO  [ecl/validation]  val:   0.0000, lp:   0.0000 mean dev:   0.0000 RMS:   0.0000 conf:   1.0000
INFO  [sensors] Temperature Compensation:
INFO  [sensors]  gyro: enabled: 0
INFO  [sensors]  accel: enabled: 0
INFO  [sensors]  baro: enabled: 0
INFO  [sensors] Airspeed status:
INFO  [ecl/validation]  no data
pxh> INFO  [commander] data link #0 lost
[Wrn] [Publisher.cc:141] Queue limit reached for topic /gazebo/default/iris_1/imu, deleting message. This warning is printed only once.
[Wrn] [Publisher.cc:141] Queue limit reached for topic /gazebo/default/iris_2/motors, deleting message. This warning is printed only once.
WARN  [commander] Preflight Fail: High Accelerometer Bias
INFO  [commander] data link #0 regained
[Wrn] [Publisher.cc:141] Queue limit reached for topic /gazebo/default/iris/gazebo/command/motor_speed, deleting message. This warning is printed only once.
[Wrn] [Publisher.cc:141] Queue limit reached for topic /gazebo/default/iris/imu, deleting message. This warning is printed only once.
[Wrn] [Publisher.cc:141] Queue limit reached for topic /gazebo/default/iris_1/motors, deleting message. This warning is printed only once.
INFO  [commander] data link #0 lost

And here are the normal values when starting Px4

NFO  [px4] Startup script returned successfully
pxh> INFO  [ecl/EKF] EKF aligned, (pressure height, IMU buf: 22, OBS buf: 14)
pxh> sensors status
INFO  [sensors] gyro status:
INFO  [ecl/validation] validator: best: 0, prev best: 0, failsafe: NO (0 events)
INFO  [ecl/validation] sensor #0, prio: 100, state: OK
INFO  [ecl/validation]  val:  -0.0058, lp:  -0.0012 mean dev:   0.0000 RMS:   0.0062 conf:   1.0000
INFO  [ecl/validation]  val:  -0.0025, lp:  -0.0054 mean dev:  -0.0000 RMS:   0.0060 conf:   1.0000
INFO  [ecl/validation]  val:  -0.0022, lp:   0.0007 mean dev:   0.0001 RMS:   0.0059 conf:   1.0000
INFO  [sensors] accel status:
INFO  [ecl/validation] validator: best: 0, prev best: 0, failsafe: NO (0 events)
INFO  [ecl/validation] sensor #0, prio: 100, state: OK
INFO  [ecl/validation]  val:  -0.1743, lp:  -0.1946 mean dev:   0.0042 RMS:   0.0711 conf:   1.0000
INFO  [ecl/validation]  val:   0.2256, lp:   0.1907 mean dev:   0.0015 RMS:   0.0704 conf:   1.0000
INFO  [ecl/validation]  val:  -9.9659, lp:  -9.9280 mean dev:  -0.0028 RMS:   0.0702 conf:   1.0000
INFO  [ecl/validation] sensor #1, prio: 75, state: OK
INFO  [ecl/validation]  val:  -0.1759, lp:  -0.1942 mean dev:   0.0031 RMS:   0.0914 conf:   1.0000
INFO  [ecl/validation]  val:   0.2254, lp:   0.1922 mean dev:  -0.0024 RMS:   0.0891 conf:   1.0000
INFO  [ecl/validation]  val:  -9.9071, lp:  -9.9303 mean dev:  -0.0023 RMS:   0.0901 conf:   1.0000
INFO  [sensors] mag status:
INFO  [ecl/validation] validator: best: 0, prev best: 0, failsafe: NO (0 events)
INFO  [ecl/validation] sensor #0, prio: 50, state: OK
INFO  [ecl/validation]  val:   0.1925, lp:   0.1975 mean dev:  -0.0010 RMS:   0.0100 conf:   1.0000
INFO  [ecl/validation]  val:  -0.0717, lp:  -0.0849 mean dev:  -0.0005 RMS:   0.0099 conf:   1.0000
INFO  [ecl/validation]  val:  -0.4296, lp:  -0.4272 mean dev:   0.0014 RMS:   0.0104 conf:   1.0000
INFO  [sensors] baro status:
INFO  [ecl/validation] validator: best: 0, prev best: 0, failsafe: NO (0 events)
INFO  [ecl/validation] sensor #0, prio: 75, state: OK
INFO  [ecl/validation]  val: 955.9479, lp: 955.9425 mean dev:  -0.0001 RMS:   0.0104 conf:   1.0000
INFO  [ecl/validation]  val:  32.0000, lp:  32.0000 mean dev:   0.0000 RMS:   0.0000 conf:   1.0000
INFO  [ecl/validation]  val:   0.0000, lp:   0.0000 mean dev:   0.0000 RMS:   0.0000 conf:   1.0000
INFO  [sensors] Temperature Compensation:
INFO  [sensors]  gyro: enabled: 0
INFO  [sensors]  accel: enabled: 0
INFO  [sensors]  baro: enabled: 0
INFO  [sensors] Airspeed status:
INFO  [ecl/validation]  no data
pxh> INFO  [ecl/EKF] EKF GPS checks passed (WGS-84 origin set)

Someone can see the problem??