Airframes - Rover bug?

Hello,

Using Qgroundcontrol 3.3.0, Ubuntu 16.04.4, PX4 Latest Stable 1.7.3

Rover not showing up in airframes options. Bug? or is there something I’m missing?

Thanks,
Shea

My guess is that somewhere along the way you flashed a version of the firmware which did not include Rover. To fix that reset your setting by going into ~/.config/org.qgroundcontrol and delete the PX4AirframeFactMetaData.xml that is in there. Now it should show back up.

I ran into the same issue and was confused as well. That fixed the problem and I have the rover airframe option now, thank you.

I am going to continue to add to this post as there is more to the story…

As Don suggested, I deleted PX4AirframeFactMetaData.xml. Rover did indeed show up. I went though the configurations, all seemed good to go. However, I was getting no output from the mains, so signal going to the servos and motors. I spent about a day troubleshooting various forum suggestions. Several have mentioned an issue cycling between Audupilot and PX4, which is exactly what I have been doing.

So, I reinstalled Ardupilot Rover. Was able to get signal to my motor and servos, though something weird was going on there like the RC was not mapped correctly though the config was correct. It did, however, verify that the hardware was working correctly. Now back to PX4, reinstalled the latest stable stack. No Rover Airframe option.

Tried on Linux machine, repeated on Windows machine…happened both places.

Seems a firmware issue when cycling between Ardu and PX4.

Any suggestions? Is there any way to completely reformat the Cube?

When you flash a PX4 firmware it sends down a new set of airframe meta data with it. This is what controls the list of airframes to choose from in the QGC ui. My guess is that whatever firmware you flashed has bad airframe meta data in it which is missing the Rover. That would be a firmware bug.

Hi there where is that file excactly?? PX4AirframeFactMetaData.xml
Is it in the qground folder ?

When you boot QGC it will write to the Console (Settings/Console) the location of the setttings directory. It’s there.

Ok, is there a specific path to the folder/ directory to follow in order to edit this bug? Please and thank you.

Flash the firmware using QGC and close the UI when finished,by restarting QGC you can get it.But the mixer file always loads failed when using the rover airframe,do you have the same issue?