(With DVR) Lost my plane because Pixhawk did not entered RTL on its own. Why?


Today I lost my plane and stuck it 80ft up in a tree. It’s still hanging on that tree and can’t get it down. Here is what happened :

EDIT : I did not even noticed that suddenly my plane was DISARMED for NO REASON ! It’s surely the cause. Can it be the failsafe channel value asking the Pixhawk to disarm, causing it to fail to RTL ?

I was flying to test the range of my plane. I was reaching 5000ft when I started to get some intermitent control loss.
So I decided to switch with my transmitter the RTL mode.
But at this point I almost had no control at all on the plane so it was too late to manually switch to RTL. So, as it always did, I was waiting for it to enter RTL on its own, as the RX was surely on failsafe.
Then it entered RTL for few seconds, then came back to STAB.
Im pretty sure it was my transmitter manually switching to RTL when signal came back for few seconds. As CIRCLE mode was never engaged (first failsafe action), im pretty sure Pixhawk NEVER engaged RTL on its own.
Then RTL kicks in again for 1s, then come back to STAB.
This happens 3/4 times.
I knew something bad was happening as it wasn’t keeping RTL mode engaged.
Why does it came back to STAB mode when I never asked him too ???
Last try before crash, I turned my transmitter OFF to be SURE to put the RX in failsafe mode.
But no. It continued in STAB mode, until it crashed on the top of a forest.

It almost looks like the failsafe action was on “STAB”, as it didn’t kept the RTL mode it entered when I asked it. But I can confirm that no, all my params are correct (I already had some failsafe actions and it came back)

I cannot understand WHY the Pixhawk did not seem to understand that my RX (EzUHF 8ch) was in failsafe. I always tested it on mission planner. Turning my transmitter OFF would make the plane go to CIRCLE for few seconds, then start RTL mode. The throttle value assigned to failsafe was way below 1000. But this day it just didn’t worked.

The failsafe value for the flight mode channel was not on RTL. Is that the cause ?? I think as soon the Pixhawk is getting invalid throttle value, it does not care about which flight mode is engaged. Or it is ? … Or is it my RX EzUHF that s*cks and just get stucked on a good throttle value for no reason ?

Here is the YouTube video with some comments.

For now the plane is still 80ft up in a tree. No idea how to get it back. Called some tree company, but it would be pretty expensive.

Can you post the log?

I haven’t recovered my plane. So no log…

Looks like you were using ArduPilot? Maybe a post at https://discuss.ardupilot.org/ might spark a discussion until you can recover the log.

Good luck.

Hello there !
I SOLVED my problem : I figured why this happened.

The reason is simple : The Throttle failsafe value that my EzUHF RX sent to the Pixhawk was not below threshold value. So my Pixhawk was thinking I still had control of the plane. That explains why Flight Mode came back to STAB and planed DISARMED : because these were the switches default failsafe positions.

But why wasn’t the throttle value low enough ? My fault : while I was sured nothing changed before this flight, I forgot few days ago I put my TX in range-test mode, which is activated by pressing the “failsafe” button. So, without noticing, I reset the failsafe channels. That caused my plane not to Return To Launch.

One thing to check before EVERY flight : turn your transmitter OFF, and see in your OSD if the plane wants to RTL. If I would have done that, I would probably have seen that the failsafe action was not kicking in.

To all EzUHF users, don’t forget that pressing FS button, no matter the purpose, will reset the failsafe channels.

Hoping this will help other beginner pilots !! CHECK YOUR FAILSAFE ACTION.

A tree climber will come rescue my plane tomorrow. Lucky it didn’t rain.

Have good flights.