WiFi Connection - RTT too high

Hey!
I’ve a Problem with my WiFi Connection.
When starting the MAVROS, I always get a “RTT is too high” error.
How can i solve that problem?
I’ve even tried the Holybro 433Mhz Module but it didn’t solve the problem either.

roslaunch mavros px4.launch fcu_url:=“tcp://192.168.0.99:6789”
… logging to /home/michi/.ros/log/eb9a0932-842a-11e8-86f8-e091f519dfb7/roslaunch-ssd05-16397.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://ssd05:36355/

SUMMARY

CLEAR PARAMETERS

  • /mavros/

PARAMETERS

  • /mavros/cmd/use_comp_id_system_control: False
  • /mavros/conn/heartbeat_rate: 1.0
  • /mavros/conn/system_time_rate: 1.0
  • /mavros/conn/timeout: 10.0
  • /mavros/conn/timesync_rate: 10.0
  • /mavros/distance_sensor/hrlv_ez4_pub/field_of_view: 0.0
  • /mavros/distance_sensor/hrlv_ez4_pub/frame_id: hrlv_ez4_sonar
  • /mavros/distance_sensor/hrlv_ez4_pub/id: 0
  • /mavros/distance_sensor/hrlv_ez4_pub/orientation: PITCH_270
  • /mavros/distance_sensor/hrlv_ez4_pub/send_tf: True
  • /mavros/distance_sensor/hrlv_ez4_pub/sensor_position/x: 0.0
  • /mavros/distance_sensor/hrlv_ez4_pub/sensor_position/y: 0.0
  • /mavros/distance_sensor/hrlv_ez4_pub/sensor_position/z: -0.1
  • /mavros/distance_sensor/laser_1_sub/id: 3
  • /mavros/distance_sensor/laser_1_sub/orientation: PITCH_270
  • /mavros/distance_sensor/laser_1_sub/subscriber: True
  • /mavros/distance_sensor/lidarlite_pub/field_of_view: 0.0
  • /mavros/distance_sensor/lidarlite_pub/frame_id: lidarlite_laser
  • /mavros/distance_sensor/lidarlite_pub/id: 1
  • /mavros/distance_sensor/lidarlite_pub/orientation: PITCH_270
  • /mavros/distance_sensor/lidarlite_pub/send_tf: True
  • /mavros/distance_sensor/lidarlite_pub/sensor_position/x: 0.0
  • /mavros/distance_sensor/lidarlite_pub/sensor_position/y: 0.0
  • /mavros/distance_sensor/lidarlite_pub/sensor_position/z: -0.1
  • /mavros/distance_sensor/sonar_1_sub/id: 2
  • /mavros/distance_sensor/sonar_1_sub/orientation: PITCH_270
  • /mavros/distance_sensor/sonar_1_sub/subscriber: True
  • /mavros/fake_gps/eph: 2.0
  • /mavros/fake_gps/epv: 2.0
  • /mavros/fake_gps/fix_type: 3
  • /mavros/fake_gps/geo_origin/alt: 408.0
  • /mavros/fake_gps/geo_origin/lat: 47.3667
  • /mavros/fake_gps/geo_origin/lon: 8.55
  • /mavros/fake_gps/gps_rate: 5.0
  • /mavros/fake_gps/mocap_transform: True
  • /mavros/fake_gps/satellites_visible: 5
  • /mavros/fake_gps/tf/child_frame_id: fix
  • /mavros/fake_gps/tf/frame_id: map
  • /mavros/fake_gps/tf/listen: False
  • /mavros/fake_gps/tf/rate_limit: 10.0
  • /mavros/fake_gps/tf/send: False
  • /mavros/fake_gps/use_mocap: True
  • /mavros/fake_gps/use_vision: False
  • /mavros/fcu_protocol: v2.0
  • /mavros/fcu_url: tcp://192.168.0.9…
  • /mavros/gcs_url:
  • /mavros/global_position/child_frame_id: base_link
  • /mavros/global_position/frame_id: map
  • /mavros/global_position/gps_uere: 1.0
  • /mavros/global_position/rot_covariance: 99999.0
  • /mavros/global_position/tf/child_frame_id: base_link
  • /mavros/global_position/tf/frame_id: map
  • /mavros/global_position/tf/global_frame_id: earth
  • /mavros/global_position/tf/send: False
  • /mavros/global_position/use_relative_alt: True
  • /mavros/image/frame_id: px4flow
  • /mavros/imu/angular_velocity_stdev: 0.000349065850399
  • /mavros/imu/frame_id: base_link
  • /mavros/imu/linear_acceleration_stdev: 0.0003
  • /mavros/imu/magnetic_stdev: 0.0
  • /mavros/imu/orientation_stdev: 1.0
  • /mavros/local_position/frame_id: map
  • /mavros/local_position/tf/child_frame_id: base_link
  • /mavros/local_position/tf/frame_id: map
  • /mavros/local_position/tf/send: False
  • /mavros/local_position/tf/send_fcu: False
  • /mavros/mission/pull_after_gcs: True
  • /mavros/mocap/use_pose: True
  • /mavros/mocap/use_tf: False
  • /mavros/odometry/frame_tf/body_frame_orientation: frd
  • /mavros/odometry/frame_tf/local_frame: vision_ned
  • /mavros/plugin_blacklist: [‘safety_area’, '…
  • /mavros/plugin_whitelist: []
  • /mavros/px4flow/frame_id: px4flow
  • /mavros/px4flow/ranger_fov: 0.118682389136
  • /mavros/px4flow/ranger_max_range: 5.0
  • /mavros/px4flow/ranger_min_range: 0.3
  • /mavros/safety_area/p1/x: 1.0
  • /mavros/safety_area/p1/y: 1.0
  • /mavros/safety_area/p1/z: 1.0
  • /mavros/safety_area/p2/x: -1.0
  • /mavros/safety_area/p2/y: -1.0
  • /mavros/safety_area/p2/z: -1.0
  • /mavros/setpoint_accel/send_force: False
  • /mavros/setpoint_attitude/reverse_thrust: False
  • /mavros/setpoint_attitude/tf/child_frame_id: target_attitude
  • /mavros/setpoint_attitude/tf/frame_id: map
  • /mavros/setpoint_attitude/tf/listen: False
  • /mavros/setpoint_attitude/tf/rate_limit: 50.0
  • /mavros/setpoint_attitude/use_quaternion: False
  • /mavros/setpoint_position/mav_frame: LOCAL_NED
  • /mavros/setpoint_position/tf/child_frame_id: target_position
  • /mavros/setpoint_position/tf/frame_id: map
  • /mavros/setpoint_position/tf/listen: False
  • /mavros/setpoint_position/tf/rate_limit: 50.0
  • /mavros/setpoint_velocity/mav_frame: LOCAL_NED
  • /mavros/startup_px4_usb_quirk: True
  • /mavros/sys/disable_diag: False
  • /mavros/sys/min_voltage: 10.0
  • /mavros/target_component_id: 1
  • /mavros/target_system_id: 1
  • /mavros/tdr_radio/low_rssi: 40
  • /mavros/time/time_ref_source: fcu
  • /mavros/time/timesync_avg_alpha: 0.6
  • /mavros/time/timesync_mode: MAVLINK
  • /mavros/vibration/frame_id: base_link
  • /mavros/vision_pose/tf/child_frame_id: vision_estimate
  • /mavros/vision_pose/tf/frame_id: map
  • /mavros/vision_pose/tf/listen: False
  • /mavros/vision_pose/tf/rate_limit: 10.0
  • /mavros/vision_speed/listen_twist: True
  • /mavros/vision_speed/twist_cov: True
  • /rosdistro: kinetic
  • /rosversion: 1.12.12

NODES
/
mavros (mavros/mavros_node)

auto-starting new master
process[master]: started with pid [16408]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to eb9a0932-842a-11e8-86f8-e091f519dfb7
process[rosout-1]: started with pid [16421]
started core service [/rosout]
process[mavros-2]: started with pid [16439]
[ INFO] [1531218051.601935345]: FCU URL: tcp://192.168.0.99:6789
[ INFO] [1531218051.603537429]: tcp0: Server address: 192.168.0.99:6789
[ INFO] [1531218051.846622817]: GCS bridge disabled
[ INFO] [1531218051.878440979]: Plugin 3dr_radio loaded
[ INFO] [1531218051.880607254]: Plugin 3dr_radio initialized
[ INFO] [1531218051.880768288]: Plugin actuator_control loaded
[ INFO] [1531218051.885063425]: Plugin actuator_control initialized
[ INFO] [1531218051.887140591]: Plugin adsb loaded
[ INFO] [1531218051.889886974]: Plugin adsb initialized
[ INFO] [1531218051.889985479]: Plugin altitude loaded
[ INFO] [1531218051.890809968]: Plugin altitude initialized
[ INFO] [1531218051.890879455]: Plugin cam_imu_sync loaded
[ INFO] [1531218051.891384417]: Plugin cam_imu_sync initialized
[ INFO] [1531218051.891490155]: Plugin command loaded
[ INFO] [1531218051.895585212]: Plugin command initialized
[ INFO] [1531218051.895667875]: Plugin debug_value loaded
[ INFO] [1531218051.899482906]: Plugin debug_value initialized
[ INFO] [1531218051.899501911]: Plugin distance_sensor blacklisted
[ INFO] [1531218051.899598665]: Plugin fake_gps loaded
[ INFO] [1531218051.912311906]: Plugin fake_gps initialized
[ INFO] [1531218051.912616373]: Plugin ftp loaded
[ INFO] [1531218051.919168345]: Plugin ftp initialized
[ INFO] [1531218051.919301841]: Plugin global_position loaded
[ INFO] [1531218051.932757749]: Plugin global_position initialized
[ INFO] [1531218051.932867605]: Plugin hil loaded
[ INFO] [1531218051.946009703]: Plugin hil initialized
[ INFO] [1531218051.946162118]: Plugin home_position loaded
[ INFO] [1531218051.949241909]: Plugin home_position initialized
[ INFO] [1531218051.949338406]: Plugin imu loaded
[ INFO] [1531218051.956062028]: Plugin imu initialized
[ INFO] [1531218051.956163998]: Plugin local_position loaded
[ INFO] [1531218051.960918562]: Plugin local_position initialized
[ INFO] [1531218051.961026467]: Plugin manual_control loaded
[ INFO] [1531218051.963787533]: Plugin manual_control initialized
[ INFO] [1531218051.963875022]: Plugin mocap_pose_estimate loaded
[ INFO] [1531218051.967708119]: Plugin mocap_pose_estimate initialized
[ INFO] [1531218051.967795339]: Plugin obstacle_distance loaded
[ INFO] [1531218051.970038290]: Plugin obstacle_distance initialized
[ INFO] [1531218051.970128314]: Plugin odom loaded
[ INFO] [1531218051.974802538]: Plugin odom initialized
[ INFO] [1531218051.975012858]: Plugin param loaded
[ INFO] [1531218051.978397134]: Plugin param initialized
[ INFO] [1531218051.978544703]: Plugin px4flow loaded
[ INFO] [1531218051.984903923]: Plugin px4flow initialized
[ INFO] [1531218051.984929467]: Plugin rangefinder blacklisted
[ INFO] [1531218051.985078197]: Plugin rc_io loaded
[ INFO] [1531218051.988352218]: Plugin rc_io initialized
[ INFO] [1531218051.988373486]: Plugin safety_area blacklisted
[ INFO] [1531218051.988488503]: Plugin setpoint_accel loaded
[ INFO] [1531218051.991510287]: Plugin setpoint_accel initialized
[ INFO] [1531218051.991690049]: Plugin setpoint_attitude loaded
[ INFO] [1531218052.001071003]: Plugin setpoint_attitude initialized
[ INFO] [1531218052.001194805]: Plugin setpoint_position loaded
[ INFO] [1531218052.015233110]: Plugin setpoint_position initialized
[ INFO] [1531218052.015377212]: Plugin setpoint_raw loaded
[ INFO] [1531218052.023519527]: Plugin setpoint_raw initialized
[ INFO] [1531218052.023631813]: Plugin setpoint_velocity loaded
[ INFO] [1531218052.028931564]: Plugin setpoint_velocity initialized
[ INFO] [1531218052.029122001]: Plugin sys_status loaded
[ INFO] [1531218052.037756370]: Plugin sys_status initialized
[ INFO] [1531218052.037908966]: Plugin sys_time loaded
[ INFO] [1531218052.044285038]: TM: Timesync mode: MAVLINK
[ INFO] [1531218052.045295383]: Plugin sys_time initialized
[ INFO] [1531218052.045405263]: Plugin trajectory loaded
[ INFO] [1531218052.050138692]: Plugin trajectory initialized
[ INFO] [1531218052.050254799]: Plugin vfr_hud loaded
[ INFO] [1531218052.050883680]: Plugin vfr_hud initialized
[ INFO] [1531218052.050905689]: Plugin vibration blacklisted
[ INFO] [1531218052.050998374]: Plugin vision_pose_estimate loaded
[ INFO] [1531218052.058066291]: Plugin vision_pose_estimate initialized
[ INFO] [1531218052.058159128]: Plugin vision_speed_estimate loaded
[ INFO] [1531218052.061959518]: Plugin vision_speed_estimate initialized
[ INFO] [1531218052.062074759]: Plugin waypoint loaded
[ INFO] [1531218052.066462039]: Plugin waypoint initialized
[ INFO] [1531218052.066589210]: Plugin wind_estimation loaded
[ INFO] [1531218052.067394728]: Plugin wind_estimation initialized
[ INFO] [1531218052.067438455]: Autostarting mavlink via USB on PX4
[ INFO] [1531218052.067538943]: Built-in SIMD instructions: SSE, SSE2
[ INFO] [1531218052.067555680]: Built-in MAVLink package version: 2018.6.6
[ INFO] [1531218052.067573594]: Known MAVLink dialects: common ardupilotmega ASLUAV autoquad icarous matrixpilot paparazzi slugs standard uAvionix ualberta
[ INFO] [1531218052.067590149]: MAVROS started. MY ID 1.240, TARGET ID 1.1
[ WARN] [1531218053.474112519]: TM : RTT too high for timesync: 828.38 ms.
[ WARN] [1531218053.592180347]: TM : RTT too high for timesync: 346.48 ms.
[ INFO] [1531218054.004098041]: CON: Got HEARTBEAT, connected. FCU: PX4 Autopilot
[ WARN] [1531218054.125162990]: TM : RTT too high for timesync: 279.65 ms.
[ INFO] [1531218054.491457160]: IMU: High resolution IMU detected!
[ WARN] [1531218054.626190088]: TM : RTT too high for timesync: 180.24 ms.
[ INFO] [1531218055.147518178]: VER: 1.1: Capabilities 0x000000000000e4ef
[ INFO] [1531218055.147638029]: VER: 1.1: Flight software: 010800ff (00000000F3E3ADAE)
[ INFO] [1531218055.147708730]: VER: 1.1: Middleware software: 010800ff (00000000F3E3ADAE)
[ INFO] [1531218055.147770755]: VER: 1.1: OS software: 071600ff (0000000000000000)
[ INFO] [1531218055.147821656]: VER: 1.1: Board hardware: 00000011
[ INFO] [1531218055.147911459]: VER: 1.1: VID/PID: 26ac:0011
[ INFO] [1531218055.147993007]: VER: 1.1: UID: 3335510f35303335
[ WARN] [1531218055.148320997]: TM : RTT too high for timesync: 102.18 ms.
[ WARN] [1531218055.526575698]: CMD: Unexpected command 520, result 0
[ WARN] [1531218056.162556478]: TM : RTT too high for timesync: 417.12 ms.
[ WARN] [1531218056.766696690]: TM : RTT too high for timesync: 420.96 ms.
[ WARN] [1531218057.578366457]: TM : RTT too high for timesync: 632.38 ms.
[ WARN] [1531218057.646065815]: TM : RTT too high for timesync: 99.89 ms.
[ WARN] [1531218058.170546951]: TM : RTT too high for timesync: 24.69 ms.
[ WARN] [1531218058.805349389]: TM : RTT too high for timesync: 59.83 ms.
[ WARN] [1531218059.458647460]: TM : RTT too high for timesync: 112.35 ms.
[ WARN] [1531218060.016798100]: TM : RTT too high for timesync: 70.44 ms.
[ WARN] [1531218060.628305920]: TM : RTT too high for timesync: 82.33 ms.
[ WARN] [1531218061.259390777]: TM : RTT too high for timesync: 112.88 ms.
[ WARN] [1531218061.794250222]: TM : RTT too high for timesync: 48.44 ms.
[ WARN] [1531218062.425796467]: TM : RTT too high for timesync: 79.56 ms.
[ WARN] [1531218063.013039406]: TM : RTT too high for timesync: 66.56 ms.
[ WARN] [1531218063.614891439]: TM : RTT too high for timesync: 69.45 ms.
[ INFO] [1531218064.005348284]: HP: requesting home position
[ WARN] [1531218064.322185101]: TM : RTT too high for timesync: 176.21 ms.
[ WARN] [1531218065.369358959]: TM : RTT too high for timesync: 223.51 ms.
[ WARN] [1531218066.168802795]: TM : RTT too high for timesync: 222.30 ms.
[ WARN] [1531218066.979839989]: TM : RTT too high for timesync: 233.69 ms.
[ WARN] [1531218067.878687508]: TM : RTT too high for timesync: 233.23 ms.
[ WARN] [1531218068.497866234]: TM : RTT too high for timesync: 51.78 ms.
[ INFO] [1531218069.077872919]: WP: mission received
[ WARN] [1531218069.078438875]: TM : RTT too high for timesync: 32.65 ms.
[ WARN] [1531218069.416856050]: PR: request param #65 timeout, retries left 2, and 47 params still missing
[ WARN] [1531218069.762507929]: TM : RTT too high for timesync: 116.39 ms.
[ WARN] [1531218070.359780260]: TM : RTT too high for timesync: 113.85 ms.
[ WARN] [1531218070.460323524]: PR: request param #72 timeout, retries left 2, and 46 params still missing
[ WARN] [1531218070.902036347]: TM : RTT too high for timesync: 56.06 ms.
[ WARN] [1531218071.535571909]: PR: request param #84 timeout, retries left 2, and 45 params still missing
[ WARN] [1531218071.667923018]: TM : RTT too high for timesync: 221.81 ms.
[ WARN] [1531218072.172602168]: TM : RTT too high for timesync: 127.17 ms.
[ WARN] [1531218072.742384351]: TM : RTT too high for timesync: 96.64 ms.
[ WARN] [1531218072.771245378]: PR: request param #108 timeout, retries left 2, and 44 params still missing
^C[mavros-2] killing on exit
[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor…
… shutting down processing monitor complete

header:
seq: 18
stamp:
secs: 1531218068
nsecs: 568927571
frame_id: ‘’
status:

level: 0
name: “mavros: FCU connection”
message: “connected”
hardware_id: “tcp://192.168.0.99:6789”
values:

key: "Received packets:"
value: "919"
  • key: “Dropped packets:”
    value: “0”
  • key: “Buffer overruns:”
    value: “0”
  • key: “Parse errors:”
    value: “0”
  • key: “Rx sequence number:”
    value: “123”
  • key: “Tx sequence number:”
    value: “200”
  • key: “Rx total bytes:”
    value: “34530”
  • key: “Tx total bytes:”
    value: “5389”
  • key: “Rx speed:”
    value: “8047.000000”
  • key: “Tx speed:”
    value: “460.000000”

level: 2
name: “mavros: GPS”
message: “No satellites”
hardware_id: “tcp://192.168.0.99:6789”
values:

key: "Satellites visible"
value: "0"
  • key: “Fix type”
    value: “0”
  • key: “EPH (m)”
    value: “Unknown”
  • key: “EPV (m)”
    value: “Unknown”

level: 0
name: “mavros: Heartbeat”
message: “Normal”
hardware_id: “tcp://192.168.0.99:6789”
values:

key: "Heartbeats since startup"
value: "15"
  • key: “Frequency (Hz)”
    value: “0.999969”
  • key: “Vehicle type”
    value: “Quadrotor”
  • key: “Autopilot type”
    value: “PX4 Autopilot”
  • key: “Mode”
    value: “MANUAL”
  • key: “System status”
    value: “Standby”

level: 0
name: “mavros: System”
message: “Normal”
hardware_id: “tcp://192.168.0.99:6789”
values:

key: "Sensor present"
value: "0x00000000"
  • key: “Sensor enabled”
    value: “0x00000000”
  • key: “Sensor helth”
    value: “0x00000000”
  • key: “CPU Load (%)”
    value: “41.2”
  • key: “Drop rate (%)”
    value: “0.0”
  • key: “Errors comm”
    value: “0”
  • key: “Errors count #1
    value: “0”
  • key: “Errors count #2
    value: “0”
  • key: “Errors count #3
    value: “0”
  • key: “Errors count #4
    value: “0”

level: 0
name: “mavros: Battery”
message: “Normal”
hardware_id: “tcp://192.168.0.99:6789”
values:

key: "Voltage"
value: "12.32"
  • key: “Current”
    value: “0.0”
  • key: “Remaining”
    value: “100.0”

level: 0
name: “mavros: Time Sync”
message: “Normal”
hardware_id: “tcp://192.168.0.99:6789”
values:

key: "Timesyncs since startup"
value: "150"
  • key: “Frequency (Hz)”
    value: “9.153596”
  • key: “Last RTT (ms)”
    value: “51.781069”
  • key: “Mean RTT (ms)”
    value: “224.284105”
  • key: “Last remote time (s)”
    value: “102.098593000”
  • key: “Estimated time offset (s)”
    value: “0.000000000”

header:
seq: 19
stamp:
secs: 1531218070
nsecs: 69060304
frame_id: ‘’
status:

level: 0
name: “mavros: FCU connection”
message: “connected”
hardware_id: “tcp://192.168.0.99:6789”
values:

key: "Received packets:"
value: "955"
  • key: “Dropped packets:”
    value: “0”
  • key: “Buffer overruns:”
    value: “0”
  • key: “Parse errors:”
    value: “0”
  • key: “Rx sequence number:”
    value: “159”
  • key: “Tx sequence number:”
    value: “222”
  • key: “Rx total bytes:”
    value: “35680”
  • key: “Tx total bytes:”
    value: “5933”
  • key: “Rx speed:”
    value: “1150.000000”
  • key: “Tx speed:”
    value: “544.000000”

level: 2
name: “mavros: GPS”
message: “No satellites”
hardware_id: “tcp://192.168.0.99:6789”
values:

key: "Satellites visible"
value: "0"
  • key: “Fix type”
    value: “0”
  • key: “EPH (m)”
    value: “Unknown”
  • key: “EPV (m)”
    value: “Unknown”

level: 0
name: “mavros: Heartbeat”
message: “Normal”
hardware_id: “tcp://192.168.0.99:6789”
values:

key: "Heartbeats since startup"
value: "17"
  • key: “Frequency (Hz)”
    value: “0.999925”
  • key: “Vehicle type”
    value: “Quadrotor”
  • key: “Autopilot type”
    value: “PX4 Autopilot”
  • key: “Mode”
    value: “MANUAL”
  • key: “System status”
    value: “Standby”

level: 0
name: “mavros: System”
message: “Normal”
hardware_id: “tcp://192.168.0.99:6789”
values:

key: "Sensor present"
value: "0x00000000"
  • key: “Sensor enabled”
    value: “0x00000000”
  • key: “Sensor helth”
    value: “0x00000000”
  • key: “CPU Load (%)”
    value: “41.2”
  • key: “Drop rate (%)”
    value: “0.0”
  • key: “Errors comm”
    value: “0”
  • key: “Errors count #1
    value: “0”
  • key: “Errors count #2
    value: “0”
  • key: “Errors count #3
    value: “0”
  • key: “Errors count #4
    value: “0”

level: 0
name: “mavros: Battery”
message: “Normal”
hardware_id: “tcp://192.168.0.99:6789”
values:

key: "Voltage"
value: "12.32"
  • key: “Current”
    value: “0.0”
  • key: “Remaining”
    value: “100.0”

level: 0
name: “mavros: Time Sync”
message: “Normal”
hardware_id: “tcp://192.168.0.99:6789”
values:

key: "Timesyncs since startup"
value: "165"
  • key: “Frequency (Hz)”
    value: “9.230091”
  • key: “Last RTT (ms)”
    value: “66.680074”
  • key: “Mean RTT (ms)”
    value: “211.941901”
  • key: “Last remote time (s)”
    value: “103.600513000”
  • key: “Estimated time offset (s)”
    value: “0.000000000”

I’m now receiving this problem too, @Michi14clp did you ever resolve the issue? How?

Hey, I faced the same problem.

Issue is that in offboard control, communication to px4 should be fast. A connection over WiFi will not give sufficient baudrate.

I used a companion computer (raspberry pi), and connected to telem 2 of pixhawk through serial connection at baudrate 921600.

This will ensure that RTT is less for mavros. Thus, run mavros on pi, but communicate to mavros through wifi of pi.

I’m pretty sure that’s what I’m doing. I have a Jetson TX2 connected to Telem 2 of PixHawk, and I’m SSHed to the Jetson over WiFi.

The initial question on this thread, was connecting to the flight controller via a TCP connection. I guess if you are going over serial, this is a different problem

In case of the Jetson, what carrier board are you using? Some carrier boards use one of the UARTs as a serial console, which makes it problematic if you are sharing it with the flight controller

For the case of using serial telemetry connection, after the timesync_rate parameter, in mavros/launch/px4_config.yaml file, changed to 0.0, the ‘RTT Too high’ problem disappeared.