Why does the drone need to change batteries after every 1min flight?

Thank you very much for your help.

Why does my drone needs to be changed batteries after every flight.

After every 1min flight,
if I unplug and plug the same battery to restart the Pixhawk, the Pixhawk keeps beeping and the GPS light blinks in red, instead of Green. Then, the drone cannot take off again with the same battery.

If I change a new battery or at the first flight, the Pixhawk will not beep and the GPS light blink green.
Then, the drone can take off with a new battery.

Therefore, I guess my QGroundcontrol setting makes the battery voltage too sensitive?

Is any my Power Section setting in QGroundControl wrong?
However, I tried the default setting and measured setting.
Both methods cannot change the situation.

My drone is DJI 550 mm Hexcopter, about 2.6 kg.

The battery size is 11.1v 5200 mah.

The battery capacity should last more than 8 min flight.
Besides, I tried four batteries so the cause may not be batteries.

Thank your help very much again.

Can you upload a log of a flight to logs.px4.io and link it here?

Since the the pixhawk only records the log when the drone successfully fly, there is no log when I use the same battery and tried to take off.

Do you know how to get the log, even when the drone did not take off ?

Thank you very much again :blush:

What does the battery icon show in QGC?

If you want to log from start to end, use this param:

1 Like

Thank you very much for the information.
I change the SDLOG_MODE from 0 to 1.
I found that the reason is the pixhawk does not get powered so there is still no log and communication lost screenshot like the below picture.

There is the video.
If I change a new battery, the drone will stop beeping and the communication will resume.
The same battery should be good after 1 min flight, because the battery sometimes can power the pixhawk for the second flight.

However, most of the time, the same battery cannot power the pixhawk for the second flight, even cannot boot the Pixhawk, either.
From my perspective, it is wired even though the voltage of the battery may slightly drop, the battery should be able at least power the Pixhawk.

My current temporary solution is that the drone needs to be changed batteries after every flight, so the wiring should be good.

I am guessing whether my power module is broken?
I also noticed that

If unplug and plug the same battery quickly (less than 1sec) after a flight, the pixhawk cannot get powered and the drone keeps beeping sound.

If unplug and wait for 10 seconds and then plug battery slowly (more than 1 sec) after a flight, the pixhawk sometimes can get powered and everything looks good, even with the same battery.

thank you very much for your help again.

So it is worrying if the Pixhawk is not powered. With a power module the Pixhawk should always get enough power, otherwise something is wrong and potentially dangerous! I can’t see all the wiring from your video but I suspect that something else is powered from the power module’s 5v and the power module can’t provide enough power so that the 5v is lower under load and things (like the Pixhawk) brown out, so can’t start or run properly.

Can you describe the power wiring of all the other components?

Thank you very much for the help again.

This is my system overview:

This is the wiring.

11.1v 5200mah battery connects a power module to 11.1 v power the motors and split 5v to Pixhawk.
11.1v 2200mah battery connects a power module to 11.1 v power the Jetson and split 5v to Iidar-lite-v3.

what i see immediately is you have used another power brick module for jetson nano and lidar sensor .
You need atleast 3.5 amps to 4 amps to power both module properly. i suggest removing that power brick module and use a 5 amp / 5v op. buck converter module to power your jetson and lidar sensor.
If this still brings up the pixhawk starting issue, connect 2 x11.2v lipoly in series (6s ~ 22v) to the brick module and check again . This should resolve all issues…

Typical issues with raspi


Thank you very much sibujacob.

Do you think the battery issue may also cause the communication issue between Jetson and Pixhawk?
Because recently during a offboard control flight,
my drone’s offboard flight mode suddenly switches to land flight mode for 0.5 second and then switch back to offboard mode repeatedly.
failed landing video (autonomous control) (13:01 missing connection) (log) (terminal)

I guess the Pixhawk losed connection with Jetson TX1 (offboard mode), so the Pixhawk switched to land flight mode automatically.
After 0.5 second, the Pixhawk re-connected the Jetson TX1 again, so the Pixhawk switched back to offboard mode again. (reference)

In a nutshell, I am not sure that the cause is Pixhawk or Jetson lack amps?
I get the entire flight log from Pixhawk and the entire rosbag record from Jetson. (rosbag video)
The log may mean that the Pixhawk and Jetson keep running during the whole flight?

Thank you very much for your further advice
Really appreciate again ^ ^

1 Like


Suggestion 1
what i would suggest here is to run the drone in position mode @ hover position for at least 5 minutes. and revert back your findings. Remove jetson out of the picture if you can . With this in place, you could understand more clearly where the fault lies.

Alternate theory
I too experienced my quadcopter having terrible flights when i shifted to PX4 v1.13.2 Currently it is grounded. PX4 v1.12.2 / 3 is highly stable version . I never had a issue with this previous PX4 version.

Second suggestion- 11 V may not be enough to run Jetson( at least raspi case as i have shown you in my video) . So to check this out, why don’t you create and see the log file on the Jetson side of things to check if Jetson is actually running stable or rebooting in the air !!

Third suggestion - Remove LIDAR sensor completely and hover in position mode and revert back with results. I see that your CPU is loading from the sampling graph.

have you checked the CG for your hexacopter with those mineral water bottles attached !


Dear sibujacob:

Thank you very much for the reply again.
For the Suggestion 1:
I use the position mode to fly the drone, with Jetson shared the power with lidar in the same configuration, but the jetson is only running rosbag record, instead of offboard control.

There is the log and video.

According to the flight controller log, there is no "AutoLand:, so it looks like that the Pixhawk always connects with Jetson.

Thus, I suspect whether the PX4-Autopiolt version should be as same as the Pixhawk flight controller, according to the similar issue: CMD: Unexpected command 176, result 0 happening and solution link.

Because my Pixhawk flight controller version is 1.13.3

my PX4-Autopilot on the Jetson TX1 is 1.14.0

Thus, I use the git checkout and switch the PX4-Autopilot to 1.13.3

I will do the further test in the following days.

For the fourth suggestion, have you checked the CG for your hexacopter with those mineral water bottles attached,
Do you mean the center of gravity (CG)? I do not exactly measure the center of gravity but those mineral water bottles are empty.

Really appreciate your help again.

1 Like

Since your original query was power related, it is better to check the drone flight with minimal components. Therefor removing jetson and LIDAR out of the pic would be the first step in I would recommend.

Also from what I understand here ,you have now similar versions of PX4 running. One on Jetson nano to run ROS instructions and the other on pixhawk to run the actual flight . Is this correct .
You have jetson nano and lidar connected on one brick module which i suspect may not be enough power to run the show. Therefore to try the minimal component theory above…::)))

1 Like

Dear sibujacob:

Thank you very much.
I will try your recommendation.
There is no jetson nano in my drone.
There is only Jetson TX1 connect with Pixhawk.
I run the offboard mode python script on Jetson TX1.

1 Like

Just want to chime in to mention there are no current reports of unstable flights with any PX4 version (as of time of writing), and you should stick with the latest stable, or development branches if you want to make sure you get the smoothest experience.

I second @sibujacob, you should try to get the pixhawk powered with nothing else next to it, and make sure it’s receiving the right amount of power.

a bit off topic but related, please make sure you take the props off your motors while testing, I saw the videos you posted and it looks a bit unsafe.


@ AlexWUrobot
Your video indicates the flight is stable. The jetson Tx1 is highly recommended for AI application. It uses 12v , 10 watts power requirements .

1 Like

@rroche …thanks for feedback. Already my drone is grounded !! ::))

1 Like

Thank you very much again.
Dear @rroche mentioned “pixhawk powered with nothing else next to it”
Could I power the Pixhawk like this?

11.1v 5200mah battery connects a power module to 11.1 v power the motors and split 5v to Pixhawk.

Dear @sibujacob
thank you very much ^^

Currently, the most challenging problem for me is the Jetson TX1 sometimes disconnect with Pixhawk.
The issue is described like this:

I will add one more 5V battery to lidar and separately use another 14.8v battery to Jetson TX1.
My current Jetson TX1 and lidar-lite-v3 consume about 1A ( tested them with power supply, there is the video)
Really appreciate your comments again ^^

According to lidar lite v3 document, it consumes 135 mA
19V Jetson TX1 requires 6.5W~15W and can consume 5.5-19.6VDC but do not over 21V

that schematic is OK… Could you please check LNDMC_XY-VEL_MAX and LNDMC_Z_VEL_MAX … …Kindly try adjusting this to a lower value and report here …Also LNDMC_TRIG_TIME …

1 Like

Thanks again.
I competed three flights with the new separately power lidar and jetson TX1 like the below picture.

1st flight (Position control) (manually remote control) log and terminal looks ok
2nd flight (Offboard control) (hover) log and terminal looks ok
3rd flight (Offboard control) (land) log and terminal shows “unexpectedly mode changed from offboard to AUTO.LAND”

The velocity looks ok at the time 1687906269. There is the full log video.

Thanks a lot again

1 Like