Use Battery Volts instead of Percentage

I’ve installed solar cell on a flying wing with the objective to prolong the flight time. However, the current battery percentage displayed by QGC v3.4 seems to be affected by the MPPT board connected in series between the the battery and the solar cells. As a result, the showing percentage is incorrect, but the voltage and the accumulative Amps are correct. Is there a way to configure QGC v3.4 to show the battery voltage instead of the percentage?

1 Like

Hi @Al_B,
Do you have more details on this build ? Auw, flight time difference with and without Solar panels …

Nice ! I have same build and have maxeon C60 sleeping.
I notice you change motor

Thank you for the report and I also prefer Voltage instead %
There is an issue open in github :

Are you referring to something like this? If so, you’ll need to click the Gear Icon and check the Voltage and Large boxes. Hope that helps.

@rollys, I was referring to the one on the top header bar. The values displayed under the HUD are the ones we now monitor. However, the Power warnings seems to be triggered by the percentage (%) instead of the voltage (v). Prompting QGC to report “Low Battery” warnings too early.

Ahhh… got it. Yes it would be nice to be able to choose what the default display instead of having to tap it for the balloon to show it. Personally, I setup the HUD and pretty much watch that instead of the header.

Good luck.

You turn off the low battery warning in QGC and just used the various low battery signals setup in the firmware.