Motors not spinning

I have a quad with dji 420s escs 310 propulsion system. I put a Pixhawk mini on it and everything works except the motors. The escs arm but the motors never spin.

I had a Pixhawk on it before and never saw this problem. Two Pixhawk mini boards and neither one works. They are running the latest stable px4 firmware.

I also tried the Auducopter firmware and received board error l3gd20


How do you tell ESCs arm? Are motors beeping?

If motors beeping, what is the beeping pattern?

When I power on the quad I hear the escs making the normal hissing sound. Then the motors beep 4 times.

Esc leds go to slow flash green and red staying lit for about 1 second each flash.

When I arm the FC safety switch goes solid lit, the leds on the escs do not change.

Qgroundcontrol says takeoff when I increase the throttle and land when I close the throttle.

Mission planner says (SAFE) in red over the HUD.



I found that the kill switch option was causing the motors to not spin even though the switch is off.

With the older FC the kill switch worked as expected. I just had to unassigned it.