Ulog streaming script doesnt work

Hello all, I’ve been working on a ulog file transfer to selected location from pixhawk via usb port. for this purpose, I try the mavlink_ulog_stream.py example under the Firmware/Tool but the script does not return any response. and also there is no error message. How should I try the sample script? where is the step I did wrong? I’m connected to pixhawk via usb port.


Do you want to download logs or to stream logs in realtime?
How do you execute the script?

With this example script, i want to stream logs in realtime witout using qgorundcontrol. I have tried this script a little while ago in hitl mode. I connected to pixhawk via usb cable and pixhawk connected to frsky radio transmitter. I gave arm command via frsky in this time script has working. There was no output from script. When i unplugged usb connection from pixhawk, I got output below :

Output file name: ./2020-01-13_10-25-20.ulg
Using port /dev/serial/by-id/usb-3D_Robotics_PX4_FMU_v5.x_0-if00
Connecting to MAVLINK...
Starting log...
Logging started. Waiting for Header...
Header received in 0.74s
Data Rate: 32.5 KB/s  Drops: 0 Traceback (most recent call last):
  File "***/site-packages/serial/serialposix.py", line 501, in read
    'device reports readiness to read but returned no data '

How can i get the log file? Should i send disarm command to reach ulg file?

You should already have the file:

The way to stop logging is just to stop the script (via Ctrl-C).

Sorry for late response, Solved problem.