Tuning EKF2_GND_EFF_DZ (ground effect dead zone)

Hi all,
I have a flamewheel f450 quadcopter frame with pixhawk v2 FMU and Tiger Motor MT-4006-13 740kv with 10" APC MC props.
I am running firmware: 1.12.1

This is a build that I’m trying to tune. The quadcopter bounces when close to the ground. I believe it’s suffering from ground effect issues with the barometer.

So…I’m trying to use this guide to tune the ground effect dead zone: Using the ECL EKF | PX4 User Guide

According to the guide, I can use the dip below the steady-state ground value (add 10%) and put that into the EKF2_GND_EFF_DZ parameter. However, I am having trouble getting a value from my logs. Take a look at my logs: https://logs.px4.io/plot_app?log=e1f63ea2-7502-45b6-b63d-222c6b775eb5

The dip is not so pronounced as in the guide.
There is a slight dip below but note the oscillations:

How do I use this information to tune the dead zone? How does the dead zone work? – Does it allow the flight controller to ignore the barometer data until a certain altitude is reached?

Maybe I’m looking at the wrong parameter. If you can spot something else in the logs, let me know.

I changed the dead zone to 20 feet and that certainly made a difference.
The bounce is something I can compensate for now by easing on the throttle.