Trying to get installer working

Iam trying to get the qground control application customized and converting it to an installer application. I followed all the steps, the application is loading in my system while I cant run it in other systems, where it shows no errors but just being loaded in the background. I don’t understand which vs dependencies Iam missing. Please someone help me with the vs installer tools that needs to be installed along with the other dependencies. I have taken more than a week to figure this out, but iam unable to do it. Please help me out with this.

Can someone suggest why this is happening. Please will be of great help

@DonLakeFlyer Might chime in?

Good luck.

@DonLakeFlyer Please do help me with this. Iam struggling for a very long time till now.

I followed the documentation and built the application from scratch. I get the application ui is not at loading. Please do help me with this. Its really very urgent.

@DonLakeFlyer I have installed all the dlls and the redistributables also but the application is still not loading. Can you please pitch in to help me. I tried downloading the qgcinstaller applcation tried installing it and after the application opened, Iam able to run my applcaton and t works totally fine. But once I uninstall the qgcs app my application does not work. What s the qgcs applicaton installng in runtime? Can you please clarify me these doubts?

If you have modified the code it could be any of a million reasons. You are going to have to debug it to see what is going on. One way to do it is to add debug output at various stages in the boot process to see where you get to. Other way is to run it in the debugger, but you’ll need PDBs for it so you can make sense of where you are at.

Other thing to verify is can you build an installer of regular QGC, no changes and does it work for you.

@DonLakeFlyer Yes the qgcs installer application works without any issues. I have the binary and it works very fine with my dependencies in the pc I built. When I take the folder somewhere else or when I use an installer application for it in a different pc, the application does not open but it simply runs in the background. I ran it in the debug mode also. The portion before the ui loading is executed successfully whereas the ui is not loaded after that. I have all the qml plugins installed too. Can you suggest where am I going wrong because I just made the ui changes in the stable version 4.0 and nothing else is changed. And can you help in letting me know where the qgc stores it runtime installations other than the regular dll’s ?

Sorry but I have no idea. When you say the UI is not loaded. For you mean it just doesn’t become visible? Or you can verify the the Qml never loads. You can put logging in the Qml as well to determine whether it is running at all.

I had this once too. It happened the first start after the installation. It was no bug at all. It simply needed more than a minute to start the ui. Maybe map related. So just start the app, and wait 20 minutes.
Further make sure no other version of QGC is started in parallel on the same machine. In that case you would get a warning window, but the window is sometimes hidden in the background, if I remember correctly.

I waited for more than 2 hours, application is not starting. It is working in 2 pc’s but does’nt work in the others. There should be some platforms dependencies Iam missing. And again when the Qgcs is already installed in my system the application works totally alright. If I uninstall the qgcs, my application will also not start

Compare both installation folders with a difference tool, like Winmerge.
Otherwise as proposed above: output log messages to console starting in Application main. And MainWindow (I forgot the exact name).

Temporary Reduce your application to just have a different name, no additional .dlls , no connection to own web services etc.

There is a new update! The application had no dependency issues at all. It works perfectly fine in the debug mode even in the other systems. The problem was with the release mode. Does anybody know why wasn’t able to work in release mode P.S I had made changes in my app settings of the .pro file. What could be the error? Why is it not working with release mode?@DonLakeFlyer can you answer this please.

And can someone let me know what are differences between the release mode and the debug mode be in the application because I have just done the ui changes to it and any major functionalities changes