Throttle in Standard Plane is reverse

I installed px4 firmare on Pixhack, everything is working perfect only the throttle thing is reverse. I have fuel engine mounted on the plan and a servo is controlling the throttle. I have Throttle channel connected at RC Channel 3. If I move my throttle stick all the way up, servo turn downs the throttle of engine, and if I move the channel all the way down, servo moves the throttle of engine to high RPM. I tried to reverse the PX4 Parameters, RC3_REV to -1, then throttle does not move to any direct, like there is not connection to Servo. Please help me, everything is set up, only this thing is messing with me.


You should just reverse the output of the channel.
I don’t know which channel you have attached to your throttle, probably channel 3.
So, go reverse it by setting PWM_MAIN_REV3 to 1

Thank you very much @nkhoit, it worked like a charm. Now I have another issue, I am using combustion engine for my plane, this combustion engine needs very little throttle for it. moving throttle to top or bottom, make my combustion engine to extra RPM. how can we set the upper and lower value for it. I did tried FW_THR_MAX and FW_THR_MIN, but it didnt help me. kindly tell me how to achieve this thing?

Hmmm, clarify what you need? I’ve never worked with combustion engines, so forgive my ignorance.
Do you need like a specific PWM range for your throttle output?

okie, I want that, if I lower the throttle stick, the servo should not go below 20% ever. If turn my throttle stick all the way up, then the servo should not move over 80%. I want to be in 20% to 80% whether I move the stick all the way down or up.

huh, that’s an interesting use-case.
I don’t think there’s a great way to set it for a single specific output channel. At least that I know of.
You can change PWM_MIN and PWM_MAX to 1200/1800. It’ll do what you want it to do for throttle, but it’ll also affect all the other outputs, including your aileron/elevator/rudder surface deflections.

There must be some way of doing this, as ArduPlane firmware has this option. I played with various params in px4, but didnt find any param that can help me in this use case. I read abot Mixer, would mixers help me?

If you’re comfortable messing around with mixers, you can find the mixer file for your airframe, modify it, and upload the firmware file.
Like here:
You’d just modify the throttle channel’s mixer output to 20% and 80%.
Gunna ping @dagar on this, he probably knows the “best” way to do this.

Thank you very much @nkhoit, this is more then enough. I am going to play with mixers, mean while I will wait the experienced guidance from @dagar.

Thank you very much again.

Hey sorry for the late reply, but you’ll want to use FW_THR_MIN, FW_THR_MAX, and FW_THR_IDLE to set appropriate limits for the combustion engine.