There is an issue about using the ublox M8N with Pixhawk

#1

Pixhawk doesn’t recognize the ublox M8N module
but connected directly to the serial I have response
$GNRMC,V,N4D
$GNVTG,N
2E
$GNGGA,0,00,99.99,56
$GNGSA,A,1,99.99,99.99,99.99
2E
$GNGSA,A,1,99.99,99.99,99.992E
$GPGSV,1,1,00
79
$GLGSV,1,1,0065
$GNGLL,V,N
7A
$GNRMC,V,N4D
$GNVTG,N
2E
$GNGGA,0,00,99.99,56
$GNGSA,A,1,99.99,99.99,99.99
2E
$GNGSA,A,1,99.99,99.99,99.992E
$GPGSV,1,1,00
79
$GLGSV,1,1,0065
$GNGLL,V,N
7A
$GNRMC,V,N4D
$GNVTG,N
2E
$GNGGA,0,00,99.99,56
$GNGSA,A,1,99.99,99.99,99.99
2E
$GNGSA,A,1,99.99,99.99,99.992E
$GPGSV,1,1,00
79
$GLGSV,1,1,0065
$GNGLL,V,N
7A
$GNRMC,V,N4D
$GNVTG,N
2E
$GNGGA,0,00,99.99,56
$GNGSA,A,1,99.99,99.99,99.99
2E

What can it be ?

#2

I found the answer in another thread. Seems like M8N often ships outputting both NMEA and UBX formatted messages and PX4 firmware doesn’t handle that well. So the solution is to go to ublox.com, download the free U-Center firmware application and disable the NMEA messages.

Or, if you are a coder, fix the firmware to allow selection of one protocol or the other and disregard/drop the other messages.

Previous thread on this: Ublox M8N with Pixhawk