TBS Crossfire PX4 Purple led fast Blinking Flight Modes change

Hi, i received pixhawk2 cube and i configured it with px4 1.5.5 firmware and tbs crossfire RC.
when i change the flight modes after arming the purple led starts blinking fast and pixhawks does not not of into the desired mode.
Please could anyone help me out in this issue its been a month i am not able to sort this issue ?

Which mode were you trying to change into? Did you connect QGroundControl? Do you get any error messages?

It’s also helpful if you post a log http://logs.px4.io/.

i used three way switch first mode is manual second is hold and third is position mode.
i connected using qgroundcontrol v3.13
no i didn’t dot any error messages.
when i change the mode purple led starts flashing and copter does not go into the desired mode.
logs: http://logs.uaventure.com/view/ACetHgYpJ6XWeA2XJAMMLS

I am also use the crossfire RX and TX.
The crossfire RX need the power input from the Pixhawk.
I have connected the Pixhawk RC cannel to the cannel 1 at the crossfire RX and select the crossfire cannel 1 as PPM output. So far I am not use the cannel 7 and 8 from the crossfire (S-Bus) as I need them for the telemetrie.
In the OGC you should see the input at the RC caibration page.
This configuration is working well so far.

Best regards,

Based on the led color you’re probably triggering a failsafe event which points to a not working setup.

This happens with the v1.5.5 PX4 Firmware but not with the v 1.6.3
Also there are no error messages in the QGC daily build.
when i switch the modes LED should be solid green but rather its flashing purple and copter starts drifting in this mode.
I am not able to figure out this problem for more than a month, i have tried three units of pixhawk 2 and same problem is persisting.
Is it that TBS crossfire not compatible with v1.5.5?
as this happens when we use crossfire but if we took a new pixhawk unit and use v1.5.5 with dJT frsky this doesn’t happens.
please help us @lorenzMeier

Markus i also did the same configuration as yours, but what PX4 firmware version are you using on pixhawk?

Are all of these mode changes intentional? http://logs.uaventure.com/view/ACetHgYpJ6XWeA2XJAMMLS

Yes these all are intentional mode changes
Have a look at this video


Hi Mridul,
I using the latest developer build (1.6.2dev).
If I ARM the system the LED keeps soild green if I have the 3D Lock on the GPS.

Best regards,

Hi Markus,

Can you please try stable v1.5.5 version and try mode change between manual , hold and position and let me know if purple led is coming or not with tbs crossfire.


Hi Mridul,
I have try the 1.5.5 and got the same problem with the purple led.
With the 1.6.3 everything fine.
The firmware from the 1.6.3 has miore then the double size of the 1.5.5.
So I think there are a lot of changes between.

Best regards,

@Markus you’re probably comparing different builds. There are 2 versions of the px4fmu-v2 binary based on usable flash storage in the autopilot. A lot changed between 1.5 and 1.6, but definitely not that much!

Purple means failsafe. Try the latest PX4, enable the new logger (SYS_LOGGER=1) and post your log here - http://logs.px4.io/

Hi Markus,
Thanks for trying the firmware.
The thing with firmware 1.6.3 is that in position mode there is a lot of drift as compared to v1.5.5
In 1.5.5 the copter would be holding its position quite firmly same with the hold mode.
We tried 1.6.3 but the results were not good as 1.5.5
@dagar the purple led problem comes when I use tbs cross fire tx Rx.
If I use fresh unit of pixhawk and use djt or xjt tx rx
With 1.5.5 purple led problem doesn’t happens.
And if once I connected the crossfire the purple led problem occurs with djt as well.
I am really confused please help me out

Please help us out if possible

@Dagar you are right, i have selected the wrong firmware 1.5.5 on the container.

But if I select the correct one (1.5.5) I am not be able to calibrate all the sensors. So it is not possible to ARM the autopilot.
After I reinstall the 1.6.4.stable all sensors are possible to calibrate and there is no purple flash led after arming the autopilot. All outputs from the autopilot are as expected.

I have had a similar problem the the crossfire and the A2 from DJI. Regardless if I used S-Bus or PPM I got a failsafe after a few minutes. Must be something on the crossfire protocol. So for the A2/ DJI I use a Futaba RX or the Lightbridge and all working well.

Regarding the “logging” I have to read the manual first. At the moment no idea how to do it right.

Best regards,

today i fly with v 1.6.4 and i gave position mode and it there was oscillations and then my copter crashed. Could any one help me out?
log: http://logs.px4.io/plot_app?log=072519a3-bb08-4b94-9887-644880aeb01b