Sudden disarm during flight at stabilize state

#1

Hi,

I had a flight using S500 and PixHawk PX4 v1.82 connected to RC and to TX1 module via UART, using mavros on the TX1 transmitting the telemetries to QGroundcontrol on remote PC(over wifi).
During the flight I’ve toggled the states on RC between mission and stabilized, at some point, after 83 seconds i had a sudden disarm in the air and the drone crashed.
At the flight logs attached below, for some reason a disarm command was triggered(blue color) during the flight and the nav_state changed to RTL.
Safety parameters at the PX4 are configured to RTL on RC lost / datalink lost, I guess it’s not what occurred here as the motors got disarm command before RTL.
What other reason can cause the manual_control_setpoint/arm_switch command?

link to log -
https://review.px4.io/plot_app?log=d887bbe7-02d9-4f9e-8c19-d6b04fe7bc76

#2

Sorry to hear about the crash. From looking at the log it looks like a strange blip happened for a moment and all your Rx input data is garbage. I wonder if the RC signal was somehow output or parsed incorrectly, or if the Rx lost connection to Tx and switched to some kind of default values? According to the log the arm switch toggles for one sample during this blip presumably causing a disarm.

Have you tested the behavior when the RC signal is lost (e.g. by turning off the Tx)? Does PX4 correctly realize that RC has been lost, or does it go to default values?

#3

@JulianOes: I just had a question coming to my mind regarding this. DJI changed the behavior, that a Disarm via CSC is no longer possible when in-flight. Instead there is a new “Emergency Stopp” Command (Thrust min & Yaw right + RTH Button). So something similar as the Kill-Switch which is already implemented. Would it make sense to do the same in PX4?

#4

@Andreas_Hoffmann yes I think that would make sense.

@itamare could it actually be that a command was sent from a ground station to disarm?

#5

Appreciate your help,
I am sure it wasn’t a command from QGC i was on the computer during the crash, by the way if the disarm command was sent from QGC would it appear at the manual_control_setpoint/arm_switch topic?

I am trying to understand how could it be that a garbage from the RC input data could cause disarm during stabilize, ran now few tests, i cannot reproduce this yet.
Tried to run the drone at stabilize mode, one time i killed the signal from the RC and second time killed the QGC, RTL worked well on both.

#6

noob here about pixhawk/px4, but i had lost a plane on a different system because of a gps wire disconnecting in flight…
.
i notice my pixhack/px4 won’t arm if some sensors are not on line.what does px4 do if it loses sensor(s) in flight (like a gps)? it certainly can’t RTL without coords. would it disarm?

#7

@itamare What was the RC-radio you were using? Did you had latest updates in to use from manufacturer?

#8

Receiver -

Transmitter -
Taranis x7